summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:21:39 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-10-29 22:21:39 +0000
commit428ec47f55adb8e3fe4925789b435427cc69cc5d (patch)
tree749e1966384df1a5cb63ccb86e0937479f61c2eb /gnome-extra/nautilus-sendto
parentNew version for GNOME 2.28. Clean up old revisions. (diff)
downloadgentoo-2-428ec47f55adb8e3fe4925789b435427cc69cc5d.tar.gz
gentoo-2-428ec47f55adb8e3fe4925789b435427cc69cc5d.tar.bz2
gentoo-2-428ec47f55adb8e3fe4925789b435427cc69cc5d.zip
New version for GNOME 2.28.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/nautilus-sendto')
-rw-r--r--gnome-extra/nautilus-sendto/ChangeLog8
-rw-r--r--gnome-extra/nautilus-sendto/nautilus-sendto-2.28.0.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/gnome-extra/nautilus-sendto/ChangeLog b/gnome-extra/nautilus-sendto/ChangeLog
index 433f2cab98d3..5ef1d17295b2 100644
--- a/gnome-extra/nautilus-sendto/ChangeLog
+++ b/gnome-extra/nautilus-sendto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/nautilus-sendto
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.29 2009/08/02 22:33:14 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/ChangeLog,v 1.30 2009/10/29 22:21:39 eva Exp $
+
+*nautilus-sendto-2.28.0 (29 Oct 2009)
+
+ 29 Oct 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +nautilus-sendto-2.28.0.ebuild:
+ New version for GNOME 2.28.
02 Aug 2009; Gilles Dartiguelongue <eva@gentoo.org> metadata.xml:
Clean up metadata.xml from old USE flag description.
diff --git a/gnome-extra/nautilus-sendto/nautilus-sendto-2.28.0.ebuild b/gnome-extra/nautilus-sendto/nautilus-sendto-2.28.0.ebuild
new file mode 100644
index 000000000000..499c45d8479a
--- /dev/null
+++ b/gnome-extra/nautilus-sendto/nautilus-sendto-2.28.0.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/nautilus-sendto/nautilus-sendto-2.28.0.ebuild,v 1.1 2009/10/29 22:21:39 eva Exp $
+
+EAPI="2"
+
+inherit gnome2 eutils autotools
+
+DESCRIPTION="A nautilus extension for sending files to locations"
+HOMEPAGE="http://www.gnome.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth empathy gajim cdr pidgin upnp" # +mail
+
+# FIXME: mail plugin build is broken
+# mail? ( >=gnome-extra/evolution-data-server-1.5.3 )
+RDEPEND=">=x11-libs/gtk+-2.12
+ >=dev-libs/glib-2.6
+ >=gnome-base/nautilus-2.14
+ >=gnome-base/gconf-2.13.0
+ bluetooth? (
+ || ( >=net-wireless/gnome-bluetooth-2.27
+ >=net-wireless/bluez-gnome-1.8 )
+ >=dev-libs/dbus-glib-0.60 )
+ cdr? (
+ || ( >=app-cdr/brasero-2.26.0[nautilus]
+ >=gnome-extra/nautilus-cd-burner-2.24.0 ) )
+ empathy? ( >=net-im/empathy-2.27.91 )
+ gajim? ( net-im/gajim
+ >=dev-libs/dbus-glib-0.60 )
+ pidgin? ( >=net-im/pidgin-2.0.0 )
+ upnp? ( >=net-libs/gupnp-0.13.0 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=gnome-base/gnome-common-0.12
+ >=dev-util/pkgconfig-0.19
+ >=dev-util/intltool-0.35"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+_use_plugin() {
+ if use ${1}; then
+ G2CONF="${G2CONF}${2:-"${1}"},"
+ fi
+}
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --with-plugins=removable-devices,"
+ _use_plugin bluetooth
+ _use_plugin cdr nautilus-burn
+# _use_plugin mail evolution
+ _use_plugin empathy
+ _use_plugin pidgin
+ _use_plugin gajim
+ _use_plugin upnp
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: skip evolution, it does not build properly
+ sed 's/evolution//g' -i Makefile.{am,in} || die "sed failed"
+
+ # Fix plugin versioning for pidgin plugin
+ epatch "${FILESDIR}/${PN}-1.1.5-pidgin-plugin-versioning.patch"
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+
+ if ! use mail; then
+ ewarn "You have disabled mail support, this will remove support for all mail clients"
+ fi
+
+ if use pidgin; then
+ elog "To enable SendTo support in pidgin, you must enable the plugin in pidgin"
+ elog "Check Tools -> Preferences -> Plugins in the pidgin menu."
+ fi
+}