summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-03-19 09:57:45 +0000
committerPacho Ramos <pacho@gentoo.org>2010-03-19 09:57:45 +0000
commit936ea8e43a35a3f65afc81bfac0953b2864c7e36 (patch)
tree903695b084f0069423e7b05cbc70063615b42e65 /gnome-base
parentamd64 stable, bug 308379 (diff)
downloadgentoo-2-936ea8e43a35a3f65afc81bfac0953b2864c7e36.tar.gz
gentoo-2-936ea8e43a35a3f65afc81bfac0953b2864c7e36.tar.bz2
gentoo-2-936ea8e43a35a3f65afc81bfac0953b2864c7e36.zip
Fix bug 285706 and bug 309621
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-vfs/ChangeLog10
-rw-r--r--gnome-base/gnome-vfs/files/gnome-vfs-2.24.2-symlink-crash.patch28
-rw-r--r--gnome-base/gnome-vfs/gnome-vfs-2.24.2-r1.ebuild133
3 files changed, 170 insertions, 1 deletions
diff --git a/gnome-base/gnome-vfs/ChangeLog b/gnome-base/gnome-vfs/ChangeLog
index 909612f9738d..60f892ba5b4c 100644
--- a/gnome-base/gnome-vfs/ChangeLog
+++ b/gnome-base/gnome-vfs/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-base/gnome-vfs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.318 2010/03/16 18:44:00 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/ChangeLog,v 1.319 2010/03/19 09:57:44 pacho Exp $
+
+*gnome-vfs-2.24.2-r1 (19 Mar 2010)
+
+ 19 Mar 2010; Pacho Ramos <pacho@gentoo.org> +gnome-vfs-2.24.2-r1.ebuild,
+ +files/gnome-vfs-2.24.2-symlink-crash.patch:
+ Fix crash if a null symlink is got (see bug #309621, thanks to Jacek for
+ reporting ubuntu/debian patch) and fix tests unsetting XAUTHORITY (see bug
+ #285706, thanks to Patrick for reporting)
16 Mar 2010; Christian Faulhammer <fauli@gentoo.org>
gnome-vfs-2.24.2.ebuild:
diff --git a/gnome-base/gnome-vfs/files/gnome-vfs-2.24.2-symlink-crash.patch b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.2-symlink-crash.patch
new file mode 100644
index 000000000000..93a6f628f6ee
--- /dev/null
+++ b/gnome-base/gnome-vfs/files/gnome-vfs-2.24.2-symlink-crash.patch
@@ -0,0 +1,28 @@
+From 92869585b2e9ab4e262f1d6b7592fe7e2c3fb327 Mon Sep 17 00:00:00 2001
+From: Alexander Larsson <alexl@redhat.com>
+Date: Wed, 10 Mar 2010 10:23:24 +0000
+Subject: Don't crash if we get a NULL symlink
+
+Patch from debian/ubuntu:
+http://launchpadlibrarian.net/35571673/gnome-vfs_2.24.2-1ubuntu2.debdiff
+---
+diff --git a/modules/ftp-method.c b/modules/ftp-method.c
+index c40c323..ac02b56 100644
+--- a/modules/ftp-method.c
++++ b/modules/ftp-method.c
+@@ -2678,7 +2678,12 @@ do_read_directory (GnomeVFSMethod *method,
+ res = GNOME_VFS_ERROR_TOO_MANY_LINKS;
+ break;
+ }
+-
++
++ if (symlink_info->symlink_name == NULL) {
++ res = GNOME_VFS_ERROR_BAD_PARAMETERS;
++ break;
++ }
++
+ symlink_name = gnome_vfs_escape_path_string (symlink_info->symlink_name);
+ gnome_vfs_file_info_clear (symlink_info);
+
+--
+cgit v0.8.3.1
diff --git a/gnome-base/gnome-vfs/gnome-vfs-2.24.2-r1.ebuild b/gnome-base/gnome-vfs/gnome-vfs-2.24.2-r1.ebuild
new file mode 100644
index 000000000000..b62d6c411a5a
--- /dev/null
+++ b/gnome-base/gnome-vfs/gnome-vfs-2.24.2-r1.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-vfs/gnome-vfs-2.24.2-r1.ebuild,v 1.1 2010/03/19 09:57:44 pacho Exp $
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="Gnome Virtual Filesystem"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="acl avahi doc fam gnutls hal ipv6 kerberos samba ssl"
+
+RDEPEND=">=gnome-base/gconf-2
+ >=dev-libs/glib-2.9.3
+ >=dev-libs/libxml2-2.6
+ app-arch/bzip2
+ fam? ( virtual/fam )
+ gnome-base/gnome-mime-data
+ >=x11-misc/shared-mime-info-0.14
+ >=dev-libs/dbus-glib-0.71
+ samba? ( >=net-fs/samba-3 )
+ gnutls? (
+ net-libs/gnutls
+ !gnome-extra/gnome-vfs-sftp )
+ ssl? (
+ !gnutls? (
+ >=dev-libs/openssl-0.9.5
+ !gnome-extra/gnome-vfs-sftp ) )
+ hal? ( >=sys-apps/hal-0.5.7 )
+ avahi? ( >=net-dns/avahi-0.6 )
+ kerberos? ( virtual/krb5 )
+ acl? (
+ sys-apps/acl
+ sys-apps/attr )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ gnome-base/gnome-common
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/gtk-doc-am-1.10-r1
+ doc? ( >=dev-util/gtk-doc-1 )"
+PDEPEND="hal? ( >=gnome-base/gnome-mount-0.6 )"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-schemas-install
+ --disable-static
+ --disable-cdda
+ --disable-howl
+ $(use_enable acl)
+ $(use_enable avahi)
+ $(use_enable fam)
+ $(use_enable gnutls)
+ $(use_enable hal)
+ $(use_enable ipv6)
+ $(use_enable kerberos krb5)
+ $(use_enable samba)
+ $(use_enable ssl openssl)"
+ # Useless ? --enable-http-neon
+
+ if use hal ; then
+ G2CONF="${G2CONF}
+ --with-hal-mount=/usr/bin/gnome-mount
+ --with-hal-umount=/usr/bin/gnome-umount
+ --with-hal-eject=/usr/bin/gnome-eject"
+ fi
+
+ # this works because of the order of configure parsing
+ # so should always be behind the use_enable options
+ # foser <foser@gentoo.org 19 Apr 2004
+ use gnutls && use ssl && G2CONF="${G2CONF} --disable-openssl"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Allow the Trash on afs filesystems (#106118)
+ epatch "${FILESDIR}"/${PN}-2.12.0-afs.patch
+
+ # Fix compiling with headers missing
+ epatch "${FILESDIR}"/${PN}-2.15.2-headers-define.patch
+
+ # Fix for crashes running programs via sudo
+ epatch "${FILESDIR}"/${PN}-2.16.0-no-dbus-crash.patch
+
+ # Fix automagic dependencies, upstream bug #493475
+ epatch "${FILESDIR}"/${PN}-2.20.0-automagic-deps.patch
+ epatch "${FILESDIR}"/${PN}-2.20.1-automagic-deps.patch
+
+ # Fix to identify ${HOME} (#200897)
+ # thanks to debian folks
+ epatch "${FILESDIR}"/${PN}-2.20.0-home_dir_fakeroot.patch
+
+ # Configure with gnutls-2.7, bug #253729
+ epatch "${FILESDIR}"/${PN}-2.24.0-gnutls27.patch
+
+ # Prevent duplicated volumes, bug #193083
+ epatch "${FILESDIR}"/${PN}-2.24.0-uuid-mount.patch
+
+ # Don't crash if we get a NULL symlink, bug #309621
+ epatch "${FILESDIR}"/${PN}-2.24.2-symlink-crash.patch
+
+ # Fix deprecated API disabling in used libraries - this is not future-proof, bug 212163
+ # upstream bug #519632
+ sed -i -e '/DISABLE_DEPRECATED/d' \
+ daemon/Makefile.am daemon/Makefile.in \
+ libgnomevfs/Makefile.am libgnomevfs/Makefile.in \
+ modules/Makefile.am modules/Makefile.in \
+ test/Makefile.am test/Makefile.in
+ sed -i -e 's:-DG_DISABLE_DEPRECATED:$(NULL):g' \
+ programs/Makefile.am programs/Makefile.in
+
+ # Fix use of broken gtk-doc.make
+ if use doc; then
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=/usr/bin/gtkdoc-rebase" -i gtk-doc.make
+ else
+ sed "/^TARGET_DIR/i \GTKDOC_REBASE=true" -i gtk-doc.make
+ fi
+
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_test() {
+ unset DISPLAY
+ # Fix bug #285706
+ unset XAUTHORITY
+ emake check || die "tests failed"
+}