summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-03-26 21:29:32 +0000
committerSamuli Suominen <drac@gentoo.org>2007-03-26 21:29:32 +0000
commite4267c01675b5ec42b541331ff26162bb25fee5b (patch)
treed2babab7711d8f9eed8284811550a18a523af5b4 /games-sports
parentAdded keyword ~x86. Bug #172262 (diff)
downloadgentoo-2-e4267c01675b5ec42b541331ff26162bb25fee5b.tar.gz
gentoo-2-e4267c01675b5ec42b541331ff26162bb25fee5b.tar.bz2
gentoo-2-e4267c01675b5ec42b541331ff26162bb25fee5b.zip
Fix linking with --as-needed.
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/toycars/ChangeLog6
-rw-r--r--games-sports/toycars/files/toycars-0.3.2-asneeded.patch13
-rw-r--r--games-sports/toycars/toycars-0.3.2.ebuild13
3 files changed, 29 insertions, 3 deletions
diff --git a/games-sports/toycars/ChangeLog b/games-sports/toycars/ChangeLog
index c53467da47b3..9450f03ed5df 100644
--- a/games-sports/toycars/ChangeLog
+++ b/games-sports/toycars/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/toycars
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/ChangeLog,v 1.2 2007/03/26 20:54:20 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/ChangeLog,v 1.3 2007/03/26 21:29:32 drac Exp $
+
+ 26 Mar 2007; Samuli Suominen <drac@gentoo.org>
+ +files/toycars-0.3.2-asneeded.patch, toycars-0.3.2.ebuild:
+ Fix linking with -Wl,--as-needed.
26 Mar 2007; <tupone@gentoo.org> toycars-0.3.2.ebuild:
Added keyword ~x86. Bug #172262 by Will Briggs
diff --git a/games-sports/toycars/files/toycars-0.3.2-asneeded.patch b/games-sports/toycars/files/toycars-0.3.2-asneeded.patch
new file mode 100644
index 000000000000..8a74ddd92ec4
--- /dev/null
+++ b/games-sports/toycars/files/toycars-0.3.2-asneeded.patch
@@ -0,0 +1,13 @@
+diff -ur toycars-0.3.2.orig/src/Makefile.am toycars-0.3.2/src/Makefile.am
+--- toycars-0.3.2.orig/src/Makefile.am 2006-08-17 09:49:48.000000000 +0300
++++ toycars-0.3.2/src/Makefile.am 2007-03-27 00:17:47.000000000 +0300
+@@ -13,6 +13,6 @@
+ ./glf/libglf.a \
+ ./MyFisix/libmyfisix.a \
+ ./Scoobie/libscoobie.a \
+- ./tinyxml/libtinyxml.a
+-
+-toycars_LDFLAGS = @SDL_LIBS@ @GLU_LIBS@
++ ./tinyxml/libtinyxml.a \
++ @SDL_LIBS@ \
++ @GLU_LIBS@
diff --git a/games-sports/toycars/toycars-0.3.2.ebuild b/games-sports/toycars/toycars-0.3.2.ebuild
index 4f2a59366bd5..9fb1e38c332e 100644
--- a/games-sports/toycars/toycars-0.3.2.ebuild
+++ b/games-sports/toycars/toycars-0.3.2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/toycars-0.3.2.ebuild,v 1.2 2007/03/26 20:54:20 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/toycars/toycars-0.3.2.ebuild,v 1.3 2007/03/26 21:29:32 drac Exp $
-inherit games
+WANT_AUTOMAKE="1.6"
+
+inherit autotools eutils games
DESCRIPTION="a physics based 2-D racer inspired by Micromachines"
HOMEPAGE="http://sourceforge.net/projects/toycars"
@@ -19,6 +21,13 @@ DEPEND="media-libs/libsdl
virtual/glu
virtual/opengl"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ eautomake
+}
+
src_install() {
dogamesbin src/${PN} || die "Failed installing ${PN} executable"
insinto "${GAMES_DATADIR}/${PN}"