summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-03-12 17:36:28 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-03-12 17:36:28 +0000
commit03d750658b00e625861483bc2c7471af00973d75 (patch)
tree68f5e5e2a231ef166b2200c282ddca37ad7e16cd /games-sports/race/race-0.5.ebuild
parentUse interpreter on ppc64 so that kaffe may be keyworded there some day too. (diff)
downloadgentoo-2-03d750658b00e625861483bc2c7471af00973d75.tar.gz
gentoo-2-03d750658b00e625861483bc2c7471af00973d75.tar.bz2
gentoo-2-03d750658b00e625861483bc2c7471af00973d75.zip
Install menu entry, bug #160244
(Portage version: 2.1.2.2)
Diffstat (limited to 'games-sports/race/race-0.5.ebuild')
-rw-r--r--games-sports/race/race-0.5.ebuild18
1 files changed, 10 insertions, 8 deletions
diff --git a/games-sports/race/race-0.5.ebuild b/games-sports/race/race-0.5.ebuild
index f1be775e0515..a39bcac1e8c8 100644
--- a/games-sports/race/race-0.5.ebuild
+++ b/games-sports/race/race-0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/race/race-0.5.ebuild,v 1.10 2005/05/17 18:55:42 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/race/race-0.5.ebuild,v 1.11 2007/03/12 17:36:28 nyhm Exp $
inherit eutils toolchain-funcs games
@@ -21,13 +21,13 @@ RDEPEND="virtual/opengl
src_unpack() {
unpack ${A}
- cd ${S}/src
- epatch ${FILESDIR}/${PV}-gentoo.patch
+ cd "${S}"/src
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
sed -i \
-e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:g" \
-e "s:GENTOO_CONFDIR:${GAMES_SYSCONFDIR}:g" \
*.c || die "sed failed"
- find "${S}"/data/ -type d -name .xvpics -print0 | xargs -0 rm -r
+ find "${S}"/data/ -type d -name .xvpics -print0 | xargs -0 rm -rf
}
src_compile() {
@@ -36,10 +36,12 @@ src_compile() {
src_install() {
dogamesbin race || die "dogamesbin failed"
- insinto ${GAMES_SYSCONFDIR}
+ insinto "${GAMES_SYSCONFDIR}"
newins config race.conf || die "newins failed"
- dodir ${GAMES_DATADIR}/${PN}
- cp -r data/* ${D}/${GAMES_DATADIR}/${PN}/ || die "cp failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r data/* || die "doins failed"
+ newicon data/sea/map.bmp ${PN}.bmp
+ make_desktop_entry race Race /usr/share/pixmaps/${PN}.bmp
dodoc README
prepgamesdirs
}