summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2014-07-01 16:02:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2014-07-01 16:02:18 +0000
commit0c8b01a0328e51b50ecc11c207ba97f7a9961d52 (patch)
treeaabcf37b63d6dc37d5770a673ddafb1916b71ffa /games-fps
parentold (diff)
downloadgentoo-2-0c8b01a0328e51b50ecc11c207ba97f7a9961d52.tar.gz
gentoo-2-0c8b01a0328e51b50ecc11c207ba97f7a9961d52.tar.bz2
gentoo-2-0c8b01a0328e51b50ecc11c207ba97f7a9961d52.zip
punt svga support
(Portage version: 2.2.8-r1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quakeforge/ChangeLog5
-rw-r--r--games-fps/quakeforge/quakeforge-0.7.2.ebuild15
2 files changed, 8 insertions, 12 deletions
diff --git a/games-fps/quakeforge/ChangeLog b/games-fps/quakeforge/ChangeLog
index 2e7588626abf..6aa7ba77551d 100644
--- a/games-fps/quakeforge/ChangeLog
+++ b/games-fps/quakeforge/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/quakeforge
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.35 2014/07/01 16:00:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/ChangeLog,v 1.36 2014/07/01 16:02:18 mr_bones_ Exp $
+
+ 01 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org> quakeforge-0.7.2.ebuild:
+ punt svga support
01 Jul 2014; Michael Sterrett <mr_bones_@gentoo.org>
-files/quakeforge-0.7.0-gentoo.patch, -quakeforge-0.7.0.ebuild:
diff --git a/games-fps/quakeforge/quakeforge-0.7.2.ebuild b/games-fps/quakeforge/quakeforge-0.7.2.ebuild
index 229f872b1de2..f84c28d8f52b 100644
--- a/games-fps/quakeforge/quakeforge-0.7.2.ebuild
+++ b/games-fps/quakeforge/quakeforge-0.7.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.7.2.ebuild,v 1.1 2013/02/02 00:07:45 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.7.2.ebuild,v 1.2 2014/07/01 16:02:18 mr_bones_ Exp $
EAPI=5
inherit base eutils autotools games
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/quake/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="cdinstall debug fbcon flac sdl svga X ncurses png vorbis zlib ipv6 xv dga alsa oss xdg wildmidi"
+IUSE="cdinstall debug fbcon flac sdl X ncurses png vorbis zlib ipv6 xv dga alsa oss xdg wildmidi"
RESTRICT="userpriv"
RDEPEND="
@@ -22,7 +22,6 @@ RDEPEND="
png? ( media-libs/libpng:0 )
flac? ( media-libs/flac )
sdl? ( media-libs/libsdl )
- svga? ( media-libs/svgalib )
X? (
x11-libs/libX11
x11-libs/libXext
@@ -59,7 +58,6 @@ src_configure() {
local clients=${QF_CLIENTS}
use fbcon && clients="${clients},fbdev"
use sdl && clients="${clients},sdl"
- use svga && clients="${clients},svga"
use X && clients="${clients},x11"
[ "${clients:0:1}" == "," ] && clients=${clients:1}
@@ -67,11 +65,6 @@ src_configure() {
local tools=${QF_TOOLS:-all}
- local svgaconf # use old school way for broken conf opts
- use svga \
- && svgaconf="--with-svga=/usr" \
- || svgaconf="--without-svga"
-
addpredict "$(games_get_libdir)"
egamesconf \
--enable-dependency-tracking \
@@ -81,7 +74,6 @@ src_configure() {
$(use_enable zlib) \
$(use_with ipv6) \
$(use_with fbcon fbdev) \
- ${svgaconf} \
$(use_with X x) \
$(use_enable xv vidmode) \
$(use_enable dga) \
@@ -95,6 +87,7 @@ src_configure() {
--enable-sound \
--disable-optimize \
--disable-Werror \
+ --without-svga \
${debugopts} \
--with-global-cfg="${GAMES_SYSCONFDIR}"/quakeforge.conf \
--with-sharepath="${GAMES_DATADIR}"/quake1 \