summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-06-22 07:51:48 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-06-22 07:51:48 +0000
commita32eeee0ac0d33a8a6b97af4a4af24bd2198bd54 (patch)
tree966927390adf796f0425780194def4aa2ccae4ed /games-engines
parentVersion bump to 1.2.3. The kernel is close to being usable, I've now been abl... (diff)
downloadgentoo-2-a32eeee0ac0d33a8a6b97af4a4af24bd2198bd54.tar.gz
gentoo-2-a32eeee0ac0d33a8a6b97af4a4af24bd2198bd54.tar.bz2
gentoo-2-a32eeee0ac0d33a8a6b97af4a4af24bd2198bd54.zip
Add support for fluidsynth (bug #137547)
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/scummvm/ChangeLog5
-rw-r--r--games-engines/scummvm/scummvm-0.8.2.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/games-engines/scummvm/ChangeLog b/games-engines/scummvm/ChangeLog
index 87dbe0b817c0..8640ac2a0736 100644
--- a/games-engines/scummvm/ChangeLog
+++ b/games-engines/scummvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-engines/scummvm
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.30 2006/04/27 19:49:31 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/ChangeLog,v 1.31 2006/06/22 07:51:48 mr_bones_ Exp $
+
+ 22 Jun 2006; Michael Sterrett <mr_bones_@gentoo.org> scummvm-0.8.2.ebuild:
+ Add support for fluidsynth (bug #137547)
27 Apr 2006; Marien Zwart <marienz@gentoo.org> files/digest-scummvm-0.8.0,
files/digest-scummvm-0.8.1, Manifest:
diff --git a/games-engines/scummvm/scummvm-0.8.2.ebuild b/games-engines/scummvm/scummvm-0.8.2.ebuild
index b4a16fa43d40..0c149e0512c5 100644
--- a/games-engines/scummvm/scummvm-0.8.2.ebuild
+++ b/games-engines/scummvm/scummvm-0.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.8.2.ebuild,v 1.1 2006/02/10 20:48:14 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-engines/scummvm/scummvm-0.8.2.ebuild,v 1.2 2006/06/22 07:51:48 mr_bones_ Exp $
inherit eutils games
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/scummvm/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~sparc ~x86"
-IUSE="alsa debug flac mp3 ogg vorbis sdl zlib"
+IUSE="alsa debug flac fluidsynth mp3 ogg vorbis sdl zlib"
RESTRICT="test" # it only looks like there's a test there #77507
RDEPEND=">=media-libs/libsdl-1.2.2
@@ -21,6 +21,7 @@ RDEPEND=">=media-libs/libsdl-1.2.2
alsa? ( >=media-libs/alsa-lib-0.9 )
mp3? ( media-libs/libmad )
flac? ( media-libs/flac )
+ fluidsynth? ( media-sound/fluidsynth )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
@@ -45,10 +46,13 @@ EOF
src_compile() {
local myconf="--backend=sdl" # x11 backend no worky (bug #83502)
- (use vorbis || use ogg) \
+ ( use vorbis || use ogg ) \
&& myconf="${myconf} --enable-vorbis" \
|| myconf="${myconf} --disable-vorbis --disable-mpeg2"
+ # bug #137547
+ use fluidsynth || myconf="${myconf} --disable-fluidsynth"
+
# NOT AN AUTOCONF SCRIPT SO DONT CALL ECONF
# mpeg2 support needs vorbis (bug #79149) so turn it off if -oggvorbis
./configure \