summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-01-07 22:47:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-01-07 22:47:18 +0000
commit8914f580d208bf70dd9d71887d3c0d4c2ab081bc (patch)
tree0729e8fa10ee5547c72c586a715ad3e4598f5a55 /games-arcade/performous
parentQA: add missing inherit for user eclass (diff)
downloadgentoo-2-8914f580d208bf70dd9d71887d3c0d4c2ab081bc.tar.gz
gentoo-2-8914f580d208bf70dd9d71887d3c0d4c2ab081bc.tar.bz2
gentoo-2-8914f580d208bf70dd9d71887d3c0d4c2ab081bc.zip
old
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-arcade/performous')
-rw-r--r--games-arcade/performous/ChangeLog9
-rw-r--r--games-arcade/performous/files/performous-0.6.1-boost150.patch102
-rw-r--r--games-arcade/performous/files/performous-0.6.1-ffmpeg.patch13
-rw-r--r--games-arcade/performous/files/performous-0.6.1-gentoo.patch29
-rw-r--r--games-arcade/performous/files/performous-0.6.1-glib232.patch10
-rw-r--r--games-arcade/performous/files/performous-0.6.1-libav.patch41
-rw-r--r--games-arcade/performous/files/performous-0.6.1-libpng.patch11
-rw-r--r--games-arcade/performous/files/performous-0.6.1-linguas.patch15
-rw-r--r--games-arcade/performous/performous-0.6.1.ebuild112
9 files changed, 8 insertions, 334 deletions
diff --git a/games-arcade/performous/ChangeLog b/games-arcade/performous/ChangeLog
index 761f7d64b35e..a82299365927 100644
--- a/games-arcade/performous/ChangeLog
+++ b/games-arcade/performous/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-arcade/performous
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.12 2013/01/03 10:57:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.13 2013/01/07 22:47:18 mr_bones_ Exp $
+
+ 07 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/performous-0.6.1-boost150.patch, -files/performous-0.6.1-ffmpeg.patch,
+ -files/performous-0.6.1-gentoo.patch, -files/performous-0.6.1-glib232.patch,
+ -files/performous-0.6.1-libav.patch, -files/performous-0.6.1-libpng.patch,
+ -files/performous-0.6.1-linguas.patch, -performous-0.6.1.ebuild:
+ old
03 Jan 2013; Agostino Sarubbo <ago@gentoo.org> performous-0.7.0.ebuild:
Stable for amd64, wrt bug #449932
diff --git a/games-arcade/performous/files/performous-0.6.1-boost150.patch b/games-arcade/performous/files/performous-0.6.1-boost150.patch
deleted file mode 100644
index d34e1b1f36f4..000000000000
--- a/games-arcade/performous/files/performous-0.6.1-boost150.patch
+++ /dev/null
@@ -1,102 +0,0 @@
---- game/filemagic.hh.old 2012-11-05 12:05:34.723680403 +0100
-+++ game/filemagic.hh 2012-11-05 12:06:06.605860472 +0100
-@@ -71,7 +71,7 @@
- // For now, just check the extension an assume it's not lying.
-
- // Get file extension in lower case
-- std::string ext = filename.extension();
-+ std::string ext = filename.extension().string();
- // somehow this does not convert the extension to lower case:
- //std::for_each(ext.begin(), ext.end(), static_cast<int(*)(int)>(std::tolower));
- std::transform(ext.begin(), ext.end(), ext.begin(), ::tolower );
---- game/songparser-ini.cc.old 2012-11-05 11:58:15.792411732 +0100
-+++ game/songparser-ini.cc 2012-11-05 11:58:59.539974896 +0100
-@@ -94,7 +94,7 @@
- // Search the dir for the music files
- for (boost::filesystem::directory_iterator dirIt(s.path), dirEnd; dirIt != dirEnd; ++dirIt) {
- boost::filesystem::path p = dirIt->path();
-- std::string name = p.leaf(); // File basename (notes.txt)
-+ std::string name = p.filename().string(); // File basename (notes.txt)
- if (regex_match(name.c_str(), match, midifile)) {
- s.midifilename = name;
- } else if (regex_match(name.c_str(), match, audiofile_background)) {
---- game/backgrounds.cc.old 2012-11-05 11:48:05.279711751 +0100
-+++ game/backgrounds.cc 2012-11-05 11:48:42.220736233 +0100
-@@ -55,8 +55,8 @@
- for (fs::directory_iterator dirIt(parent), dirEnd; m_loading && dirIt != dirEnd; ++dirIt) {
- fs::path p = dirIt->path();
- if (fs::is_directory(p)) { reload_internal(p); continue; }
-- std::string name = p.leaf(); // File basename
-- std::string path = p.directory_string(); // Path without filename
-+ std::string name = p.filename().string(); // File basename
-+ std::string path = p.string(); // Path without filename
- path.erase(path.size() - name.size());
- if (!regex_match(name.c_str(), match, expression)) continue;
- {
---- game/xtime.hh.old 2012-11-05 11:04:23.511731845 +0100
-+++ game/xtime.hh 2012-11-05 11:19:13.960930800 +0100
-@@ -1,5 +1,6 @@
- #pragma once
-
-+#include <boost/version.hpp>
- #include <boost/thread/xtime.hpp>
- #include <cmath>
-
-@@ -20,7 +21,11 @@
- }
- boost::xtime now() {
- boost::xtime time;
-+#if BOOST_VERSION >= 105000
-+ boost::xtime_get(&time, boost::TIME_UTC_);
-+#else
- boost::xtime_get(&time, boost::TIME_UTC);
-+#endif
- return time;
- }
- double seconds(boost::xtime const& time) {
---- game/fs.cc.old 2012-11-05 11:23:41.147282412 +0100
-+++ game/fs.cc 2012-11-05 11:24:55.219383768 +0100
-@@ -127,7 +127,7 @@
-
- bool isThemeResource(fs::path filename){
- try {
-- std::string themefile = getThemePath(filename.filename());
-+ std::string themefile = getThemePath(filename.filename().string());
- return themefile == filename;
- } catch (...) { return false; }
- }
---- game/cache.cc.old 2012-11-05 10:51:36.981446602 +0100
-+++ game/cache.cc 2012-11-05 10:51:53.491277792 +0100
-@@ -9,7 +9,7 @@
- fs::path constructSVGCacheFileName(fs::path const& svgfilename, double factor){
- fs::path cache_filename;
- std::string const lod = (boost::format("%.2f") % factor).str();
-- std::string const cache_basename = svgfilename.filename() + ".cache_" + lod + ".png";
-+ std::string const cache_basename = svgfilename.filename().string() + ".cache_" + lod + ".png";
-
- if (isThemeResource(svgfilename)) {
- std::string const theme_name = (config["game/theme"].s().empty() ? "default" : config["game/theme"].s());
---- game/songs.cc.old 2012-11-05 11:35:51.876756665 +0100
-+++ game/songs.cc 2012-11-05 11:36:55.805536727 +0100
-@@ -67,8 +67,8 @@
- for (fs::directory_iterator dirIt(parent), dirEnd; m_loading && dirIt != dirEnd; ++dirIt) {
- fs::path p = dirIt->path();
- if (fs::is_directory(p)) { reload_internal(p); continue; }
-- std::string name = p.leaf(); // File basename (notes.txt)
-- std::string path = p.directory_string(); // Path without filename
-+ std::string name = p.filename().string(); // File basename (notes.txt)
-+ std::string path = p.string(); // Path without filename
- path.erase(path.size() - name.size());
- if (!regex_match(name.c_str(), match, expression)) continue;
- try {
---- game/songparser.cc.old 2012-11-05 11:26:13.314214039 +0100
-+++ game/songparser.cc 2012-11-05 11:27:58.917214975 +0100
-@@ -101,7 +101,7 @@
-
- for (boost::filesystem::directory_iterator dirIt(s.path), dirEnd; dirIt != dirEnd; ++dirIt) {
- boost::filesystem::path p = dirIt->path();
-- std::string name = p.leaf(); // File basename
-+ std::string name = p.filename().string(); // File basename
- if (m_song.cover.empty() && regex_match(name.c_str(), match, coverfile)) {
- m_song.cover = name;
- } else if (m_song.background.empty() && regex_match(name.c_str(), match, backgroundfile)) {
diff --git a/games-arcade/performous/files/performous-0.6.1-ffmpeg.patch b/games-arcade/performous/files/performous-0.6.1-ffmpeg.patch
deleted file mode 100644
index 38adb751d3b1..000000000000
--- a/games-arcade/performous/files/performous-0.6.1-ffmpeg.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- game/ffmpeg.cc.old 2012-02-19 09:01:01.086108323 +0100
-+++ game/ffmpeg.cc 2012-02-19 09:02:27.157984673 +0100
-@@ -60,8 +60,8 @@
- for (unsigned int i=0; i<pFormatCtx->nb_streams; i++) {
- AVCodecContext* cc = pFormatCtx->streams[i]->codec;
- cc->workaround_bugs = FF_BUG_AUTODETECT;
-- if (videoStream == -1 && cc->codec_type==CODEC_TYPE_VIDEO) videoStream = i;
-- if (audioStream == -1 && cc->codec_type==CODEC_TYPE_AUDIO) audioStream = i;
-+ if (videoStream == -1 && cc->codec_type==AVMEDIA_TYPE_VIDEO) videoStream = i;
-+ if (audioStream == -1 && cc->codec_type==AVMEDIA_TYPE_AUDIO) audioStream = i;
- }
- if (videoStream == -1 && decodeVideo) throw std::runtime_error("No video stream found");
- if (audioStream == -1 && decodeAudio) throw std::runtime_error("No audio stream found");
diff --git a/games-arcade/performous/files/performous-0.6.1-gentoo.patch b/games-arcade/performous/files/performous-0.6.1-gentoo.patch
deleted file mode 100644
index e9a6fe316b95..000000000000
--- a/games-arcade/performous/files/performous-0.6.1-gentoo.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- game/CMakeLists.txt.old 2012-02-20 13:19:35.219635192 +0100
-+++ game/CMakeLists.txt 2012-02-20 13:20:06.025469808 +0100
-@@ -149,5 +149,5 @@
- configure_file("${CMAKE_CURRENT_SOURCE_DIR}/config.cmake.hh" "${CMAKE_CURRENT_BINARY_DIR}/config.hh" @ONLY)
- include_directories("${CMAKE_CURRENT_BINARY_DIR}")
-
--install(TARGETS performous DESTINATION bin)
-+install(TARGETS performous DESTINATION @GENTOO_BINDIR@)
-
---- game/fs.cc.old 2012-02-20 20:09:48.171892171 +0100
-+++ game/fs.cc 2012-02-20 20:16:14.197400202 +0100
-@@ -195,6 +195,7 @@
- if (root) config_list.push_back(std::string(root) + "/" SHARED_DATA_DIR + configFile.string());
- fs::path exec = plugin::execname();
- if (!exec.empty()) config_list.push_back(exec.parent_path().string() + "/../" SHARED_DATA_DIR + configFile.string());
-+ config_list.push_back(SHARED_DATA_DIR + configFile.string());
- ConfigList::const_iterator it = std::find_if(config_list.begin(), config_list.end(), static_cast<bool(&)(fs::path const&)>(fs::exists));
- if (it == config_list.end()) {
- throw std::runtime_error("Could not find default config file " + configFile.string());
---- game/fs.cc.old 2012-02-20 20:49:35.610728056 +0100
-+++ game/fs.cc 2012-02-20 20:57:03.117084432 +0100
-@@ -167,6 +167,7 @@
-
- // Adding relative path from executable
- dirs.push_back(plugin::execname().parent_path().parent_path() / shareDir);
-+ dirs.push_back(shareDir);
- #ifndef _WIN32
- // Adding XDG_DATA_DIRS
- {
diff --git a/games-arcade/performous/files/performous-0.6.1-glib232.patch b/games-arcade/performous/files/performous-0.6.1-glib232.patch
deleted file mode 100644
index f69d52253fe4..000000000000
--- a/games-arcade/performous/files/performous-0.6.1-glib232.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- game/unicode.cc.old 2012-06-27 13:34:43.485706157 +0200
-+++ game/unicode.cc 2012-06-27 13:34:56.825769500 +0200
-@@ -2,7 +2,6 @@
-
- #include <boost/scoped_ptr.hpp>
- #include <glibmm/ustring.h>
--#include <glib/gconvert.h>
- #include <sstream>
- #include <stdexcept>
-
diff --git a/games-arcade/performous/files/performous-0.6.1-libav.patch b/games-arcade/performous/files/performous-0.6.1-libav.patch
deleted file mode 100644
index b598dc0a488a..000000000000
--- a/games-arcade/performous/files/performous-0.6.1-libav.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -urN Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake
---- Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:44:26.112930173 +0200
-+++ Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:56:10.229914635 +0200
-@@ -25,9 +25,15 @@
- if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
- set(AVUtil_INCLUDE "${suffix}avutil.h")
- endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
-+ if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
-+ set(AVUtilMath_INCLUDE "${suffix}mathematics.h")
-+ endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
- endif(NOT AVUtil_INCLUDE)
- endforeach(suffix)
-
-+ if(NOT AVUtilMath_INCLUDE)
-+ message(FATAL_ERROR "Found mathematics.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
-+ endif(NOT AVUtilMath_INCLUDE)
- if(NOT AVUtil_INCLUDE)
- message(FATAL_ERROR "Found avutil.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
- endif(NOT AVUtil_INCLUDE)
-diff -urN Performous-0.6.1-Source.old/game/config.cmake.hh Performous-0.6.1-Source/game/config.cmake.hh
---- Performous-0.6.1-Source.old/game/config.cmake.hh 2012-05-16 13:44:26.103930173 +0200
-+++ Performous-0.6.1-Source/game/config.cmake.hh 2012-05-16 13:59:24.552910345 +0200
-@@ -15,6 +15,7 @@
- #define AVCODEC_INCLUDE <@AVCodec_INCLUDE@>
- #define AVFORMAT_INCLUDE <@AVFormat_INCLUDE@>
- #define SWSCALE_INCLUDE <@SWScale_INCLUDE@>
-+#define AVUTILMATH_INCLUDE <@AVUtilMath_INCLUDE@>
-
- #endif
-
-diff -urN Performous-0.6.1-Source.old/game/ffmpeg.cc Performous-0.6.1-Source/game/ffmpeg.cc
---- Performous-0.6.1-Source.old/game/ffmpeg.cc 2012-05-16 13:44:26.101930173 +0200
-+++ Performous-0.6.1-Source/game/ffmpeg.cc 2012-05-16 14:00:38.278908717 +0200
-@@ -10,6 +10,7 @@
- #include AVCODEC_INCLUDE
- #include AVFORMAT_INCLUDE
- #include SWSCALE_INCLUDE
-+#include AVUTILMATH_INCLUDE
- }
-
- // #define USE_FFMPEG_CRASH_RECOVERY
diff --git a/games-arcade/performous/files/performous-0.6.1-libpng.patch b/games-arcade/performous/files/performous-0.6.1-libpng.patch
deleted file mode 100644
index 2633e77c0fbb..000000000000
--- a/games-arcade/performous/files/performous-0.6.1-libpng.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- game/image.hh.old 2012-02-19 09:20:09.215987761 +0100
-+++ game/image.hh 2012-02-19 09:20:50.418077218 +0100
-@@ -26,7 +26,7 @@
- }
- void loadPNG_internal(png_structp pngPtr, png_infop infoPtr, std::ifstream& file, std::vector<unsigned char>& image, std::vector<png_bytep>& rows, unsigned& w, unsigned& h) {
- if (setjmp(png_jmpbuf(pngPtr))) throw std::runtime_error("Reading PNG failed");
-- png_set_read_fn(pngPtr,(voidp)&file, readPngHelper);
-+ png_set_read_fn(pngPtr,(png_voidp)&file, readPngHelper);
- png_read_info(pngPtr, infoPtr);
- png_set_expand(pngPtr); // Expand everything to RGB(A)
- png_set_strip_16(pngPtr); // Strip everything down to 8 bit/component
diff --git a/games-arcade/performous/files/performous-0.6.1-linguas.patch b/games-arcade/performous/files/performous-0.6.1-linguas.patch
deleted file mode 100644
index 21836766d878..000000000000
--- a/games-arcade/performous/files/performous-0.6.1-linguas.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- lang/CMakeLists.txt
-+++ lang/CMakeLists.txt
-@@ -7,5 +7,11 @@
- set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
- add_custom_command(OUTPUT ${mofile} COMMAND ${Msgfmt_BIN} -v "${pofile}" -o ${mofile} MAIN_DEPENDENCY ${pofile} COMMENT "Building ${language} locale" VERBATIM)
- add_custom_target(locale_${language} ALL DEPENDS ${mofile}) # Make sure the mofiles are always built
-- install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
- endforeach(language)
-+foreach(language $ENV{LINGUAS})
-+ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
-+ if (EXISTS ${pofile})
-+ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
-+ install(FILES ${mofile} DESTINATION ${LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
-+ endif()
-+endforeach(language)
diff --git a/games-arcade/performous/performous-0.6.1.ebuild b/games-arcade/performous/performous-0.6.1.ebuild
deleted file mode 100644
index f1dfb9ee610f..000000000000
--- a/games-arcade/performous/performous-0.6.1.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-0.6.1.ebuild,v 1.10 2012/11/05 11:44:38 tupone Exp $
-
-EAPI="3"
-
-inherit flag-o-matic base cmake-utils games
-
-MY_PN=Performous
-MY_P=${MY_PN}-${PV}
-SONGS_PN=ultrastar-songs
-
-DESCRIPTION="SingStar GPL clone"
-HOMEPAGE="http://sourceforge.net/projects/performous/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}-Source.tar.bz2
- songs? (
- mirror://sourceforge/${PN}/${SONGS_PN}-restricted-3.zip
- mirror://sourceforge/${PN}/${SONGS_PN}-jc-1.zip
- mirror://sourceforge/${PN}/${SONGS_PN}-libre-3.zip
- mirror://sourceforge/${PN}/${SONGS_PN}-shearer-1.zip
- )"
-
-LICENSE="GPL-2
- songs? (
- CCPL-Attribution-ShareAlike-NonCommercial-2.5
- CCPL-Attribution-NonCommercial-NoDerivs-2.5
- )"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="songs tools"
-
-RDEPEND="dev-cpp/glibmm
- dev-cpp/libxmlpp
- media-libs/portaudio
- >=dev-libs/boost-1.36
- dev-libs/glib
- dev-libs/libxml2
- gnome-base/librsvg
- media-gfx/imagemagick
- virtual/jpeg
- media-libs/libpng
- media-libs/libsdl
- virtual/ffmpeg
- virtual/opengl
- virtual/glu
- sys-libs/zlib
- x11-libs/cairo
- x11-libs/gdk-pixbuf
- x11-libs/pango"
-DEPEND="${RDEPEND}
- media-libs/glew
- sys-apps/help2man"
-
-S=${WORKDIR}/${MY_P}-Source
-
-PATCHES=(
- "${FILESDIR}"/${P}-ffmpeg.patch
- "${FILESDIR}"/${P}-libav.patch
- "${FILESDIR}"/${P}-libpng.patch
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-linguas.patch
- "${FILESDIR}"/${P}-glib232.patch
- "${FILESDIR}"/${P}-boost150.patch
-)
-
-src_prepare() {
- base_src_prepare
- sed -i \
- -e "s:@GENTOO_BINDIR@:${GAMES_BINDIR}:" \
- game/CMakeLists.txt \
- || die
-
- strip-linguas -u lang
-
- # how do I hate boost? Let me count the ways...
- local boost_ver=$(best_version ">=dev-libs/boost-1.36")
-
- boost_ver=${boost_ver/*boost-/}
- boost_ver=${boost_ver%.*}
- boost_ver=${boost_ver/./_}
-
- einfo "Using boost version ${boost_ver}"
- append-cxxflags \
- -I/usr/include/boost-${boost_ver}
- append-ldflags \
- -L/usr/$(get_libdir)/boost-${boost_ver}
- export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
- export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_enable tools TOOLS)
- -DCMAKE_VERBOSE_MAKEFILE=TRUE
- -DSHARE_INSTALL="${GAMES_DATADIR}"/${PN}
- )
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
- if use songs ; then
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r "${WORKDIR}/songs" || die
- fi
- dodoc docs/{Authors,DeveloperReadme,instruments,TODO}.txt
- prepgamesdirs
-}