summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-07-23 19:44:43 +0000
committerMichael Januszewski <spock@gentoo.org>2008-07-23 19:44:43 +0000
commit952fe3ba58307d087a9e34160d765a3cc3629440 (patch)
treecf6e5dd30d1e3e030e0d84b1162b257aef94a2f7 /dev-util/oprofile
parentAdd patch to fix parsing of resolv.conf by host/dig, #231247 (diff)
downloadgentoo-2-952fe3ba58307d087a9e34160d765a3cc3629440.tar.gz
gentoo-2-952fe3ba58307d087a9e34160d765a3cc3629440.tar.bz2
gentoo-2-952fe3ba58307d087a9e34160d765a3cc3629440.zip
Version bump.
(Portage version: 2.2_rc2/cvs/Linux 2.6.26 x86_64)
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/ChangeLog8
-rw-r--r--dev-util/oprofile/oprofile-0.9.4.ebuild73
2 files changed, 80 insertions, 1 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index d4e7c07f82d7..eba4a7e638b0 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/oprofile
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.48 2008/05/31 15:12:26 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.49 2008/07/23 19:44:43 spock Exp $
+
+*oprofile-0.9.4 (23 Jul 2008)
+
+ 23 Jul 2008; Michał Januszewski <spock@gentoo.org>
+ +oprofile-0.9.4.ebuild:
+ Version bump (bug #232690).
31 May 2008; Michał Januszewski <spock@gentoo.org>
files/oprofile-0.9.3-gcc43.patch:
diff --git a/dev-util/oprofile/oprofile-0.9.4.ebuild b/dev-util/oprofile/oprofile-0.9.4.ebuild
new file mode 100644
index 000000000000..55beb5aab060
--- /dev/null
+++ b/dev-util/oprofile/oprofile-0.9.4.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.4.ebuild,v 1.1 2008/07/23 19:44:43 spock Exp $
+
+inherit eutils qt3 linux-info
+
+DESCRIPTION="A transparent low-overhead system-wide profiler"
+HOMEPAGE="http://oprofile.sourceforge.net"
+SRC_URI="mirror://sourceforge/oprofile/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+# IUSE: it also needs kernel sources but all gentoo users have them
+IUSE="qt3"
+DEPEND=">=dev-libs/popt-1.7-r1
+ >=sys-devel/binutils-2.14.90.0.6-r3
+ >=sys-libs/glibc-2.3.2-r1
+ qt3? ( $(qt_min_version 3.3) )"
+
+src_compile() {
+ local myconf=""
+
+ if use qt3
+ then
+ REALHOME="$HOME"
+ mkdir -p "$T"/fakehome/.kde
+ mkdir -p "$T"/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ # things that should access the real homedir
+ [ -d "$REALHOME/.ccache" ] && ln -sf "$REALHOME/.ccache" "$HOME/"
+ else
+ myconf="${myconf} --with-qt-dir=/void"
+ fi
+
+ myconf="${myconf} --with-x"
+
+ case ${KV_FULL} in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=${KV_DIR}";;
+ 2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
+ *) die "Kernel version '${KV_FULL}' not supported";;
+ esac
+ econf ${myconf} || die "econf failed"
+
+ local mymake=""
+
+ sed -i -e "s,depmod -a,:,g" Makefile
+ emake ${mymake} || die "emake failed"
+}
+
+src_install() {
+ local myinst=""
+
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV_FULL}"
+ make DESTDIR="${D}" ${myinst} install || die "make install failed"
+
+ dodoc ChangeLog* README TODO
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == / ]] ; then
+ [[ -x /sbin/update-modules ]] && /sbin/update-modules || /sbin/modules-update
+ fi
+
+ echo
+ elog "Now load the oprofile module by running:"
+ elog " # opcontrol --init"
+ elog "Then read manpages and this html doc:"
+ elog " /usr/share/doc/oprofile/oprofile.html"
+ echo
+}