summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2014-07-16 05:16:53 +0000
committerHans de Graaff <graaff@gentoo.org>2014-07-16 05:16:53 +0000
commit7f5495d942ea93e5a35346fcb333f2a08606a13c (patch)
treeffb7f9e046be712bca3670498374950764cc1d78 /dev-ruby/oauth2
parentCleanup. (diff)
downloadgentoo-2-7f5495d942ea93e5a35346fcb333f2a08606a13c.tar.gz
gentoo-2-7f5495d942ea93e5a35346fcb333f2a08606a13c.tar.bz2
gentoo-2-7f5495d942ea93e5a35346fcb333f2a08606a13c.zip
Version bump.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
Diffstat (limited to 'dev-ruby/oauth2')
-rw-r--r--dev-ruby/oauth2/ChangeLog7
-rw-r--r--dev-ruby/oauth2/oauth2-1.0.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-ruby/oauth2/ChangeLog b/dev-ruby/oauth2/ChangeLog
index 841b0c3952d9..ad5d52647bbc 100644
--- a/dev-ruby/oauth2/ChangeLog
+++ b/dev-ruby/oauth2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/oauth2
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.21 2014/07/16 05:10:12 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/ChangeLog,v 1.22 2014/07/16 05:16:53 graaff Exp $
+
+*oauth2-1.0.0 (16 Jul 2014)
+
+ 16 Jul 2014; Hans de Graaff <graaff@gentoo.org> +oauth2-1.0.0.ebuild:
+ Version bump.
16 Jul 2014; Hans de Graaff <graaff@gentoo.org> -oauth2-0.9.2.ebuild,
-oauth2-0.9.3.ebuild:
diff --git a/dev-ruby/oauth2/oauth2-1.0.0.ebuild b/dev-ruby/oauth2/oauth2-1.0.0.ebuild
new file mode 100644
index 000000000000..b532370066b8
--- /dev/null
+++ b/dev-ruby/oauth2/oauth2-1.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/oauth2/oauth2-1.0.0.ebuild,v 1.1 2014/07/16 05:16:53 graaff Exp $
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+RUBY_FAKEGEM_TASK_TEST="none"
+RUBY_FAKEGEM_TASK_DOC="doc:rdoc"
+
+RUBY_FAKEGEM_DOCDIR="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="Ruby wrapper for the OAuth 2.0 protocol built with a similar style to the original OAuth gem."
+HOMEPAGE="http://github.com/intridea/oauth2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/faraday-0.8
+ >=dev-ruby/jwt-1.0 =dev-ruby/jwt-1*
+ >=dev-ruby/multi_json-1.3 =dev-ruby/multi_json-1*
+ >=dev-ruby/multi_xml-0.5:0
+ >=dev-ruby/rack-1.2"
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-2.5.0:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/^end/ s:^:#:' spec/helper.rb || die
+
+ sed -i -e '/yardstick/,/^end/ s:^:#:' Rakefile || die
+}
+
+each_ruby_test() {
+ CI=true ${RUBY} -S rspec spec || die
+}