summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2010-10-03 20:53:09 +0000
committerUlrich Müller <ulm@gentoo.org>2010-10-03 20:53:09 +0000
commitb572b4537d3ef548d40d3ceb9bb1c1e029530b0e (patch)
tree24a04e83fa23df3a1660bf1b714edeb3f3a97957 /dev-python
parentVersion bump (bug #338530). (diff)
downloadgentoo-2-b572b4537d3ef548d40d3ceb9bb1c1e029530b0e.tar.gz
gentoo-2-b572b4537d3ef548d40d3ceb9bb1c1e029530b0e.tar.bz2
gentoo-2-b572b4537d3ef548d40d3ceb9bb1c1e029530b0e.zip
Initial import, bug 338553.
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/ropemacs/ChangeLog11
-rw-r--r--dev-python/ropemacs/files/ropemacs-0.6-ropemode-dir.patch11
-rw-r--r--dev-python/ropemacs/metadata.xml6
-rw-r--r--dev-python/ropemacs/ropemacs-0.6.ebuild47
4 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/ropemacs/ChangeLog b/dev-python/ropemacs/ChangeLog
new file mode 100644
index 000000000000..58ebcfef10c6
--- /dev/null
+++ b/dev-python/ropemacs/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-python/ropemacs
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ropemacs/ChangeLog,v 1.1 2010/10/03 20:53:09 ulm Exp $
+
+*ropemacs-0.6 (03 Oct 2010)
+
+ 03 Oct 2010; Ulrich Mueller <ulm@gentoo.org> +ropemacs-0.6.ebuild,
+ +files/ropemacs-0.6-ropemode-dir.patch, +metadata.xml:
+ Initial import. Ebuild contributed by Yang Zhang <zyangmath@gmail.com> in
+ bug 338553.
+
diff --git a/dev-python/ropemacs/files/ropemacs-0.6-ropemode-dir.patch b/dev-python/ropemacs/files/ropemacs-0.6-ropemode-dir.patch
new file mode 100644
index 000000000000..496841c388ff
--- /dev/null
+++ b/dev-python/ropemacs/files/ropemacs-0.6-ropemode-dir.patch
@@ -0,0 +1,11 @@
+--- ropemacs-orig/setup.py
++++ ropemacs/setup.py
+@@ -23,7 +23,7 @@
+ version='0.6',
+ description='An emacs mode for using rope python refactoring library',
+ long_description=get_long_description(),
+- packages=['ropemode', 'ropemacs'],
++ packages=['ropemacs'],
+ author='Ali Gholami Rudi',
+ author_email='aligrudi@users.sourceforge.net',
+ url='http://rope.sf.net/ropemacs.html',
diff --git a/dev-python/ropemacs/metadata.xml b/dev-python/ropemacs/metadata.xml
new file mode 100644
index 000000000000..9d638908c7da
--- /dev/null
+++ b/dev-python/ropemacs/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<herd>emacs</herd>
+</pkgmetadata>
diff --git a/dev-python/ropemacs/ropemacs-0.6.ebuild b/dev-python/ropemacs/ropemacs-0.6.ebuild
new file mode 100644
index 000000000000..6439514a1a57
--- /dev/null
+++ b/dev-python/ropemacs/ropemacs-0.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/ropemacs/ropemacs-0.6.ebuild,v 1.1 2010/10/03 20:53:09 ulm Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2:2.5"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="2.4 3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Rope in Emacs"
+HOMEPAGE="http://rope.sourceforge.net/ropemacs.html
+ http://pypi.python.org/pypi/ropemacs"
+SRC_URI="http://bitbucket.org/agr/ropemacs/get/8b277a188d00.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="dev-python/rope
+ dev-python/ropemode"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Patch for nonexistent ropemode in setup.py
+ epatch "${FILESDIR}/${P}-ropemode-dir.patch"
+}
+
+src_install() {
+ distutils_src_install
+ dodoc docs/*.txt || die
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ elog "In order to enable ropemacs support in Emacs, install"
+ elog "app-emacs/pymacs and add the following line to your ~/.emacs file:"
+ elog " (pymacs-load \"ropemacs\" \"rope-\")"
+}