summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-27 04:51:37 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-27 04:51:37 +0000
commit1f5eaa9e8c913a1ee3d7383a02f3667194dae887 (patch)
treea6a1be53ea4d01919f1caedbee3abebb2553574d /dev-python/oslotest
parentfixed typo in patchset (diff)
downloadgentoo-2-1f5eaa9e8c913a1ee3d7383a02f3667194dae887.tar.gz
gentoo-2-1f5eaa9e8c913a1ee3d7383a02f3667194dae887.tar.bz2
gentoo-2-1f5eaa9e8c913a1ee3d7383a02f3667194dae887.zip
add py3.3 support to support same for oslo-config, add IUSE doc and doc build
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/ChangeLog5
-rw-r--r--dev-python/oslotest/oslotest-1.1.0.ebuild17
2 files changed, 18 insertions, 4 deletions
diff --git a/dev-python/oslotest/ChangeLog b/dev-python/oslotest/ChangeLog
index 194b2f69aeb8..4b3a6e661962 100644
--- a/dev-python/oslotest/ChangeLog
+++ b/dev-python/oslotest/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/oslotest
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/ChangeLog,v 1.2 2014/09/22 21:25:31 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/ChangeLog,v 1.3 2014/09/27 04:51:37 idella4 Exp $
+
+ 27 Sep 2014; Ian Delaney <idella4@gentoo.org> oslotest-1.1.0.ebuild:
+ add py3.3 support to support same for oslo-config, add IUSE doc and doc build
*oslotest-1.1.0 (22 Sep 2014)
diff --git a/dev-python/oslotest/oslotest-1.1.0.ebuild b/dev-python/oslotest/oslotest-1.1.0.ebuild
index f13cc4bdfdaf..09396ca81c4a 100644
--- a/dev-python/oslotest/oslotest-1.1.0.ebuild
+++ b/dev-python/oslotest/oslotest-1.1.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/oslotest-1.1.0.ebuild,v 1.1 2014/09/22 21:25:31 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/oslotest-1.1.0.ebuild,v 1.2 2014/09/27 04:51:37 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_3} )
inherit distutils-r1
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
+IUSE="doc test"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
@@ -39,6 +39,17 @@ RDEPEND=">=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
# This time half the doc files are missing; Do you want them?
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
python_test() {
nosetests tests/ || die "test failed under ${EPYTHON}"
}
+
+src_install() {
+ local HTML_DOCS=( doc/pyasn1-tutorial.html )
+ use doc && HTML_DOCS=( doc/build/html/. )
+
+ distutils-r1_src_install
+}