summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-07-28 14:36:55 +0000
committerIan Delaney <idella4@gentoo.org>2013-07-28 14:36:55 +0000
commitbfb630ef4824381127a35ad1d6534f9b7b55516a (patch)
treee478333d487558a827c6c25519943045bc96e3e2 /dev-python/optcomplete
parentuse proper MULTILIB_USEDEP instead of emul libs (diff)
downloadgentoo-2-bfb630ef4824381127a35ad1d6534f9b7b55516a.tar.gz
gentoo-2-bfb630ef4824381127a35ad1d6534f9b7b55516a.tar.bz2
gentoo-2-bfb630ef4824381127a35ad1d6534f9b7b55516a.zip
migrate -> distutils-r1, keep -1.2 stable
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/optcomplete')
-rw-r--r--dev-python/optcomplete/ChangeLog10
-rw-r--r--dev-python/optcomplete/optcomplete-1.2-r1.ebuild26
2 files changed, 33 insertions, 3 deletions
diff --git a/dev-python/optcomplete/ChangeLog b/dev-python/optcomplete/ChangeLog
index b7540c028735..175e980daffa 100644
--- a/dev-python/optcomplete/ChangeLog
+++ b/dev-python/optcomplete/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/optcomplete
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/optcomplete/ChangeLog,v 1.9 2012/05/15 16:24:51 darkside Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/optcomplete/ChangeLog,v 1.10 2013/07/28 14:36:55 idella4 Exp $
+
+*optcomplete-1.2-r1 (28 Jul 2013)
+
+ 28 Jul 2013; Ian Delaney <idella4@gentoo.org> +optcomplete-1.2-r1.ebuild:
+ migrate -> distutils-r1, keep -1.2 stable
15 May 2012; Jeremy Olexa <darkside@gentoo.org> optcomplete-1.2.ebuild:
add ~x86-linux, bug 416007 by Dan Wallis
@@ -34,4 +39,3 @@
25 Jun 2008; Ali Polatel <hawking@gentoo.org> +metadata.xml,
+optcomplete-1.2.ebuild:
Initial ebuild for optcomplete.
-
diff --git a/dev-python/optcomplete/optcomplete-1.2-r1.ebuild b/dev-python/optcomplete/optcomplete-1.2-r1.ebuild
new file mode 100644
index 000000000000..b370deaf7e42
--- /dev/null
+++ b/dev-python/optcomplete/optcomplete-1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/optcomplete/optcomplete-1.2-r1.ebuild,v 1.1 2013/07/28 14:36:55 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="Shell completion self-generator for Python"
+HOMEPAGE="http://furius.ca/optcomplete/ http://pypi.python.org/pypi/optcomplete"
+SRC_URI="http://furius.ca/downloads/${PN}/releases/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux"
+IUSE="doc examples"
+
+DEPEND=""
+RDEPEND=""
+
+python_install_all() {
+ use examples && local EXAMPLES=( bin/. )
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}