summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-20 16:20:48 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-03-20 16:20:48 +0000
commitbbdf41b21e7467f9cf764111282e424481b63529 (patch)
treef096f4e35a1b7e215ac98ebd315e3b234215375e /dev-python/bsddb3
parentBlocking of app-text/dos2unix-5 because it bundles unix2dos, updated Homepage (diff)
downloadgentoo-2-bbdf41b21e7467f9cf764111282e424481b63529.tar.gz
gentoo-2-bbdf41b21e7467f9cf764111282e424481b63529.tar.bz2
gentoo-2-bbdf41b21e7467f9cf764111282e424481b63529.zip
Fix dependencies and simplify tests.
(Portage version: 15835-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/bsddb3')
-rw-r--r--dev-python/bsddb3/bsddb3-4.8.1.ebuild8
-rw-r--r--dev-python/bsddb3/bsddb3-4.8.3.ebuild10
2 files changed, 13 insertions, 5 deletions
diff --git a/dev-python/bsddb3/bsddb3-4.8.1.ebuild b/dev-python/bsddb3/bsddb3-4.8.1.ebuild
index a75c09b8f34b..103720113606 100644
--- a/dev-python/bsddb3/bsddb3-4.8.1.ebuild
+++ b/dev-python/bsddb3/bsddb3-4.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.8.1.ebuild,v 1.4 2010/01/10 18:32:49 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.8.1.ebuild,v 1.5 2010/03/20 16:20:48 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -18,6 +18,7 @@ IUSE="doc"
RDEPEND=">=sys-libs/db-4.6"
DEPEND="${RDEPEND}
+ dev-python/setuptools
doc? ( dev-python/sphinx )"
DOCS="TODO.txt"
@@ -50,7 +51,10 @@ src_compile() {
src_test() {
tests() {
rm -fr /tmp/z-Berkeley_DB
- python_set_build_dir_symlink
+ rm -f build
+ ln -s build-${PYTHON_ABI} build
+
+ echo "$(PYTHON)" test.py
"$(PYTHON)" test.py
}
python_execute_function tests
diff --git a/dev-python/bsddb3/bsddb3-4.8.3.ebuild b/dev-python/bsddb3/bsddb3-4.8.3.ebuild
index 60029b6622d5..30a098f94755 100644
--- a/dev-python/bsddb3/bsddb3-4.8.3.ebuild
+++ b/dev-python/bsddb3/bsddb3-4.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.8.3.ebuild,v 1.2 2010/03/07 12:58:09 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/bsddb3/bsddb3-4.8.3.ebuild,v 1.3 2010/03/20 16:20:48 arfrever Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -19,7 +19,8 @@ IUSE=""
# IUSE="doc"
RDEPEND=">=sys-libs/db-4.6"
-DEPEND="${RDEPEND}"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
# doc? ( dev-python/sphinx )
DOCS="TODO.txt"
@@ -57,7 +58,10 @@ src_compile() {
src_test() {
tests() {
- python_set_build_dir_symlink
+ rm -f build
+ ln -s build-${PYTHON_ABI} build
+
+ echo BSDDB_TEST_PATH="${T}/tests-${PYTHON_ABI}" "$(PYTHON)" test.py
BSDDB_TEST_PATH="${T}/tests-${PYTHON_ABI}" "$(PYTHON)" test.py
}
python_execute_function tests