summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-07-06 18:25:41 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-07-06 18:25:41 +0000
commit95359af61e4ed24017099d4b2b49fcf32a8bcc01 (patch)
tree3db838d9354183fc59cb2d90e08212037b1cd312 /dev-ml/bin-prot
parentremove old (diff)
downloadgentoo-2-95359af61e4ed24017099d4b2b49fcf32a8bcc01.tar.gz
gentoo-2-95359af61e4ed24017099d4b2b49fcf32a8bcc01.tar.bz2
gentoo-2-95359af61e4ed24017099d4b2b49fcf32a8bcc01.zip
remove old
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/bin-prot')
-rw-r--r--dev-ml/bin-prot/ChangeLog6
-rw-r--r--dev-ml/bin-prot/bin-prot-1.2.24.ebuild44
-rw-r--r--dev-ml/bin-prot/bin-prot-1.3.0.ebuild63
3 files changed, 5 insertions, 108 deletions
diff --git a/dev-ml/bin-prot/ChangeLog b/dev-ml/bin-prot/ChangeLog
index 2f2dd4dd6fe7..1d89ca657b5c 100644
--- a/dev-ml/bin-prot/ChangeLog
+++ b/dev-ml/bin-prot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ml/bin-prot
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.9 2011/06/25 18:56:12 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/ChangeLog,v 1.10 2011/07/06 18:25:41 aballier Exp $
+
+ 06 Jul 2011; Alexis Ballier <aballier@gentoo.org> -bin-prot-1.2.24.ebuild,
+ -bin-prot-1.3.0.ebuild:
+ remove old
*bin-prot-1.3.1 (25 Jun 2011)
diff --git a/dev-ml/bin-prot/bin-prot-1.2.24.ebuild b/dev-ml/bin-prot/bin-prot-1.2.24.ebuild
deleted file mode 100644
index 24fa3027482b..000000000000
--- a/dev-ml/bin-prot/bin-prot-1.2.24.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-1.2.24.ebuild,v 1.1 2010/12/16 22:14:18 aballier Exp $
-
-EAPI="2"
-
-inherit findlib
-
-DESCRIPTION="Automated code generation for converting OCaml values to/from a type-safe binary protocol"
-HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
-SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="doc test"
-S=${WORKDIR}/${P}/lib
-
-RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt]
- dev-ml/type-conv"
-DEPEND="${RDEPEND}
- test? ( dev-ml/ounit )
- doc? ( virtual/latex-base )"
-
-src_compile() {
- emake -j1 CFLAGS="${CFLAGS}" || die
- if use doc; then
- cd ../doc
- VARTEXFONTS="${T}/fonts" pdflatex README.tex || die
- fi
-}
-
-src_test() {
- cd "${S}/../lib_test"
- emake -j1 || die
- ./test_runner || die
-}
-
-src_install() {
- findlib_src_preinst
- emake install || die "make install failed"
- dodoc ../README.txt ../Changelog
- use doc && dodoc ../doc/README.pdf
-}
diff --git a/dev-ml/bin-prot/bin-prot-1.3.0.ebuild b/dev-ml/bin-prot/bin-prot-1.3.0.ebuild
deleted file mode 100644
index 8c352215a489..000000000000
--- a/dev-ml/bin-prot/bin-prot-1.3.0.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/bin-prot/bin-prot-1.3.0.ebuild,v 1.2 2011/02/22 16:06:36 aballier Exp $
-
-EAPI=3
-
-EAPI="2"
-
-inherit findlib eutils multilib
-
-DESCRIPTION="A binary protocol generator"
-HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
-SRC_URI="http://www.janestreet.com/ocaml/bin_prot-${PV}.tar.gz"
-
-LICENSE="LGPL-2.1-linking-exception"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE="debug doc +ocamlopt"
-
-RDEPEND=">=dev-lang/ocaml-3.11[ocamlopt?]
- dev-ml/findlib
- >=dev-ml/ounit-1.0.2
- >=dev-ml/type-conv-2.0.1"
-DEPEND="${RDEPEND}
- >=dev-ml/ounit-1.0.2
- doc? ( virtual/latex-base )"
-
-S=${WORKDIR}/${PN}
-
-oasis_use_enable() {
- echo "--override $2 `use $1 && echo \"true\" || echo \"false\"`"
-}
-
-src_configure() {
- ./configure --prefix usr \
- --libdir /usr/$(get_libdir) \
- --destdir "${D}" \
- $(oasis_use_enable debug debug) \
- $(oasis_use_enable ocamlopt is_native) \
- || die
-}
-
-src_compile() {
- emake || die
- if use doc ; then
- cd "${S}/doc"
- pdflatex README || die
- pdflatex README || die
- fi
-}
-
-src_test() {
- LD_LIBRARY_PATH="${S}/_build/lib" emake test || die
-}
-
-src_install() {
- findlib_src_install
-
- dodoc README Changelog || die
- if use doc; then
- dodoc doc/README.pdf || die
- fi
-}