summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-02 20:29:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-02 20:29:39 +0000
commitc38c2c7cc3275bf0adbfa1c3b18024050ab47300 (patch)
treed387757957d923e16811039d6d6ea48a282eefe2 /dev-libs/newt
parentDelete older ebuilds. (diff)
downloadgentoo-2-c38c2c7cc3275bf0adbfa1c3b18024050ab47300.tar.gz
gentoo-2-c38c2c7cc3275bf0adbfa1c3b18024050ab47300.tar.bz2
gentoo-2-c38c2c7cc3275bf0adbfa1c3b18024050ab47300.zip
Delete calls to deprecated python_version().
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/newt')
-rw-r--r--dev-libs/newt/ChangeLog6
-rw-r--r--dev-libs/newt/newt-0.52.10-r1.ebuild11
2 files changed, 9 insertions, 8 deletions
diff --git a/dev-libs/newt/ChangeLog b/dev-libs/newt/ChangeLog
index 732742a37547..439d2690c3b9 100644
--- a/dev-libs/newt/ChangeLog
+++ b/dev-libs/newt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-libs/newt
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.62 2010/06/02 06:13:08 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/ChangeLog,v 1.63 2010/06/02 20:29:39 arfrever Exp $
+
+ 02 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ newt-0.52.10-r1.ebuild:
+ Delete calls to deprecated python_version().
02 Jun 2010; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove xmerlin from metadata.xml (#69210)
diff --git a/dev-libs/newt/newt-0.52.10-r1.ebuild b/dev-libs/newt/newt-0.52.10-r1.ebuild
index e6307e99f2be..6b210b0a5894 100644
--- a/dev-libs/newt/newt-0.52.10-r1.ebuild
+++ b/dev-libs/newt/newt-0.52.10-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.10-r1.ebuild,v 1.7 2009/10/26 08:40:07 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/newt/newt-0.52.10-r1.ebuild,v 1.8 2010/06/02 20:29:39 arfrever Exp $
inherit python toolchain-funcs eutils rpm
@@ -43,8 +43,6 @@ src_unpack() {
}
src_compile() {
- python_version
-
econf \
$(use_with gpm gpm-support) \
$(use_with tcl) \
@@ -53,13 +51,12 @@ src_compile() {
# not parallel safe
emake -j1 \
CC="$(tc-getCC)" \
- PYTHONVERS="python${PYVER}" \
+ PYTHONVERS="$(PYTHON)" \
RPM_OPT_FLAGS="${CFLAGS}" \
|| die "emake failed"
}
src_install () {
- python_version
# the RPM_OPT_FLAGS="ERROR" is there to catch a build error
# if it fails, that means something in src_compile() didn't build properly
# not parallel safe
@@ -67,7 +64,7 @@ src_install () {
DESTDIR="${D}" \
prefix="/usr" \
libdir="/usr/$(get_libdir)" \
- PYTHONVERS="python${PYVER}" \
+ PYTHONVERS="$(PYTHON)" \
RPM_OPT_FLAGS="ERROR" \
install || die "make install failed"
dodoc peanuts.py popcorn.py tutorial.sgml