summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-09-14 21:13:39 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-09-14 21:13:39 +0000
commitd6472d3ea766b747c76e587eff42585b6e80b418 (patch)
tree938a28b64cfb2e0ed84fa792c1abe5a7a208f8b6 /dev-libs/libsigc++
parentstable x86, bug 284776 (diff)
downloadgentoo-2-d6472d3ea766b747c76e587eff42585b6e80b418.tar.gz
gentoo-2-d6472d3ea766b747c76e587eff42585b6e80b418.tar.bz2
gentoo-2-d6472d3ea766b747c76e587eff42585b6e80b418.zip
Version bump. Updated documentation & support for devhelp.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'dev-libs/libsigc++')
-rw-r--r--dev-libs/libsigc++/ChangeLog10
-rw-r--r--dev-libs/libsigc++/libsigc++-2.2.4.2.ebuild (renamed from dev-libs/libsigc++/libsigc++-2.2.2.ebuild)46
2 files changed, 29 insertions, 27 deletions
diff --git a/dev-libs/libsigc++/ChangeLog b/dev-libs/libsigc++/ChangeLog
index f860e9c5b403..5225a03b62af 100644
--- a/dev-libs/libsigc++/ChangeLog
+++ b/dev-libs/libsigc++/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-libs/libsigc++
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.143 2009/02/27 14:32:32 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/ChangeLog,v 1.144 2009/09/14 21:13:39 eva Exp $
+
+*libsigc++-2.2.4.2 (14 Sep 2009)
+
+ 14 Sep 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ -libsigc++-2.2.2.ebuild, +libsigc++-2.2.4.2.ebuild:
+ Version bump. Updated documentation & support for devhelp.
27 Feb 2009; Brent Baude <ranger@gentoo.org> libsigc++-2.2.3.ebuild:
stable ppc64, bug 255844
diff --git a/dev-libs/libsigc++/libsigc++-2.2.2.ebuild b/dev-libs/libsigc++/libsigc++-2.2.4.2.ebuild
index 1baab0bfafc8..86e74e4c8a97 100644
--- a/dev-libs/libsigc++/libsigc++-2.2.2.ebuild
+++ b/dev-libs/libsigc++/libsigc++-2.2.4.2.ebuild
@@ -1,24 +1,24 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.2.2.ebuild,v 1.7 2008/12/07 12:05:29 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libsigc++/libsigc++-2.2.4.2.ebuild,v 1.1 2009/09/14 21:13:39 eva Exp $
-inherit eutils gnome.org flag-o-matic
+EAPI="2"
+
+inherit base eutils gnome.org flag-o-matic
DESCRIPTION="Typesafe callback system for standard C++"
HOMEPAGE="http://libsigc.sourceforge.net/"
LICENSE="LGPL-2.1"
SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="debug doc test"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc test"
- # don't waste time building examples/docs
- sed -i 's|^\(SUBDIRS =.*\)docs examples\(.*\)$|\1\2|' Makefile.in || \
- die "sed docs/examples failed"
+# Needs mm-common for eautoreconf
+src_prepare() {
+ # don't waste time building examples
+ sed -i 's|^\(SUBDIRS =.*\)examples\(.*\)$|\1\2|' Makefile.in || \
+ die "sed examples failed"
# don't waste time building tests unless USE=test
if ! use test ; then
@@ -27,31 +27,27 @@ src_unpack() {
fi
# fix image paths
- if use doc ; then
- sed -i 's|../../images/||g' docs/reference/html/*.html || \
- die "sed failed"
- fi
+# if use doc ; then
+# sed -i 's|../../images/||g' docs/reference/html/*.html || \
+# die "sed failed"
+# fi
}
src_compile() {
filter-flags -fno-exceptions
- local myconf
- use debug \
- && myconf="--enable-debug=yes" \
- || myconf="--enable-debug=no"
+ local myconf="$myconf $(use_enable doc documentation)"
econf ${myconf} || die "econf failed."
- emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed."
- rm -fr "${D}"/usr/share
- dodoc AUTHORS ChangeLog README NEWS TODO
+ emake DESTDIR="${D}" install || die "make install failed."
+ #rm -fr "${D}"/usr/share
+ dodoc AUTHORS ChangeLog README NEWS TODO || die "dodoc failed"
if use doc ; then
- dohtml -r docs/reference/html/* docs/images/*
+ dohtml -r docs/reference/html/* docs/images/* || die "dohtml failed"
cp -R examples "${D}"/usr/share/doc/${PF}/
fi
}