summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2007-02-04 00:11:13 +0000
committerVlastimil Babka <caster@gentoo.org>2007-02-04 00:11:13 +0000
commit64a9262a091c0d1cf6e4cf6feff95af03f5ee93a (patch)
tree6bf0ba8442573e1108e4614341571f854dd611f8 /dev-java
parentVersion bump (1.0) + removal of pre-released ebuilds (diff)
downloadgentoo-2-64a9262a091c0d1cf6e4cf6feff95af03f5ee93a.tar.gz
gentoo-2-64a9262a091c0d1cf6e4cf6feff95af03f5ee93a.tar.bz2
gentoo-2-64a9262a091c0d1cf6e4cf6feff95af03f5ee93a.zip
Cleanup.
(Portage version: 2.1.2-r7)
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/jython/ChangeLog6
-rw-r--r--dev-java/jython/files/digest-jython-2.1-r63
-rw-r--r--dev-java/jython/files/jython7
-rw-r--r--dev-java/jython/files/jythonc2
-rw-r--r--dev-java/jython/jython-2.1-r6.ebuild84
5 files changed, 5 insertions, 97 deletions
diff --git a/dev-java/jython/ChangeLog b/dev-java/jython/ChangeLog
index 6e56050b330a..380b87e87752 100644
--- a/dev-java/jython/ChangeLog
+++ b/dev-java/jython/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/jython
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.47 2007/02/03 12:56:40 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/ChangeLog,v 1.48 2007/02/04 00:11:13 caster Exp $
+
+ 04 Feb 2007; Vlastimil Babka <caster@gentoo.org> -files/jython,
+ -files/jythonc, -jython-2.1-r6.ebuild:
+ Cleanup.
03 Feb 2007; Steve Dibb <beandog@gentoo.org> jython-2.1-r10.ebuild:
amd64 stable, bug 162038
diff --git a/dev-java/jython/files/digest-jython-2.1-r6 b/dev-java/jython/files/digest-jython-2.1-r6
deleted file mode 100644
index 430b21a5c3b2..000000000000
--- a/dev-java/jython/files/digest-jython-2.1-r6
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 74f21a0185135396c71453bc279c179f jython-2.1.tar.bz2 1301528
-RMD160 94ae22604c1a816af7d066f2ed88b2abaf5c51d1 jython-2.1.tar.bz2 1301528
-SHA256 faa57a55d137268e80221cd628b234ca67de13504b813be1c0499c9f4d5872b2 jython-2.1.tar.bz2 1301528
diff --git a/dev-java/jython/files/jython b/dev-java/jython/files/jython
deleted file mode 100644
index 402f84dd67aa..000000000000
--- a/dev-java/jython/files/jython
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/bin/sh
-
-exec $(java-config --java) \
- -Djava.library.path="$(java-config -i libreadline-java)" \
- -Dpython.home="/usr/share/jython" \
- -classpath "${CLASSPATH}:$(java-config --classpath=jython,libreadline-java 2>/dev/null)" \
- "org.python.util.jython" "$@"
diff --git a/dev-java/jython/files/jythonc b/dev-java/jython/files/jythonc
deleted file mode 100644
index 39efd0611dc4..000000000000
--- a/dev-java/jython/files/jythonc
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-jython "/usr/share/jython/tools/jythonc/jythonc.py" "$@"
diff --git a/dev-java/jython/jython-2.1-r6.ebuild b/dev-java/jython/jython-2.1-r6.ebuild
deleted file mode 100644
index a50cd986793f..000000000000
--- a/dev-java/jython/jython-2.1-r6.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jython/jython-2.1-r6.ebuild,v 1.6 2007/01/21 10:36:57 betelgeuse Exp $
-
-inherit java-pkg
-
-DESCRIPTION="An implementation of Python written in Java"
-HOMEPAGE="http://www.jython.org"
-MY_PV="21"
-#SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.class"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="JPython"
-SLOT="0"
-KEYWORDS="x86 ppc amd64 ppc64"
-IUSE="readline jikes source doc"
-# servlet
-
-RDEPEND=">=virtual/jre-1.2
- readline? ( >=dev-java/libreadline-java-0.8.0 )
- jikes? ( >=dev-java/jikes-1.18 )"
-# servlet? ( >=net-www/tomcat-5.0 )
-DEPEND=">=virtual/jdk-1.2
- source? ( app-arch/zip )
- ${RDEPEND}"
-
-src_compile() {
- javac=$(java-config -c)
- if use jikes ; then
- java=$(which jikes)
- fi
-
- local cp="."
- local exclude=""
-
- if use readline ; then
- cp=${cp}:$(java-pkg_getjars libreadline-java)
- else
- exclude="${exclude} ! -name ReadlineConsole.java"
- fi
-
- #if use servlet; then
- # cp=${cp}:$(java-pkg_getjars servlet)
- #else
- exclude="${exclude} ! -name PyServlet.java"
- #fi
-
- find org -name "*.java" ${exclude} | xargs ${javac} -source 1.3 -classpath ${cp} -nowarn || die "Failed to compile"
-
- find org -name "*.class" | xargs jar cf ${PN}.jar
-}
-
-src_install() {
- java-pkg_dojar ${PN}.jar
-
- dodoc README.txt NEWS ACKNOWLEDGMENTS
- use doc && java-pkg_dohtml -A .css .jpg .gif -r Doc/*
- newbin ${FILESDIR}/jython jython
- newbin ${FILESDIR}/jythonc jythonc
-
- dodir /usr/share/jython/cachedir
- chmod a+rw ${D}/usr/share/jython/cachedir
-
- rm Demo/jreload/example.jar
- insinto /usr/share/${PN}
- doins -r Lib Demo registry
-
- insinto /usr/share/${PN}/tools
- doins -r Tools/*
-
- use source && java-pkg_dosrc com org
-}
-
-pkg_postinst() {
- if use readline; then
- elog "To use readline you need to add the following to your registry"
- elog
- elog "python.console=org.python.util.ReadlineConsole"
- elog "python.console.readlinelib=GnuReadline"
- elog
- elog "The global registry can be found in /usr/share/${PN}/registry"
- elog "User registry in \$HOME/.jython"
- elog "See http://www.jython.org/docs/registry.html for more information"
- fi
-}