summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-11-14 22:03:47 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-11-14 22:03:47 +0000
commit22bbb02d73417f868509fb10c13b5170d1d9dceb (patch)
treefda9d500d820c8f7843e049c2c1a44c2fc3ad4ff /dev-haskell/dbus
parentNew package: fast binary serialization library (a depend for dev-util/bustle-... (diff)
downloadgentoo-2-22bbb02d73417f868509fb10c13b5170d1d9dceb.tar.gz
gentoo-2-22bbb02d73417f868509fb10c13b5170d1d9dceb.tar.bz2
gentoo-2-22bbb02d73417f868509fb10c13b5170d1d9dceb.zip
New package: dbus client library (a depend for dev-util/bustle-0.4.2)
(Portage version: 2.2.0_alpha142_p19/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/dbus')
-rw-r--r--dev-haskell/dbus/ChangeLog9
-rw-r--r--dev-haskell/dbus/dbus-0.10.4.ebuild37
-rw-r--r--dev-haskell/dbus/metadata.xml60
3 files changed, 106 insertions, 0 deletions
diff --git a/dev-haskell/dbus/ChangeLog b/dev-haskell/dbus/ChangeLog
new file mode 100644
index 000000000000..3e7a6a946567
--- /dev/null
+++ b/dev-haskell/dbus/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-haskell/dbus
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dbus/ChangeLog,v 1.1 2012/11/14 22:03:47 slyfox Exp $
+
+*dbus-0.10.4 (14 Nov 2012)
+
+ 14 Nov 2012; Sergei Trofimovich <slyfox@gentoo.org> +dbus-0.10.4.ebuild,
+ +metadata.xml:
+ New package: dbus client library (a depend for dev-util/bustle-0.4.2)
diff --git a/dev-haskell/dbus/dbus-0.10.4.ebuild b/dev-haskell/dbus/dbus-0.10.4.ebuild
new file mode 100644
index 000000000000..1648a092a827
--- /dev/null
+++ b/dev-haskell/dbus/dbus-0.10.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/dbus/dbus-0.10.4.ebuild,v 1.1 2012/11/14 22:03:47 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A client library for the D-Bus IPC system."
+HOMEPAGE="https://john-millikin.com/software/haskell-dbus/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/cereal-0.3.4:=[profile?]
+ <dev-haskell/cereal-0.4:=[profile?]
+ =dev-haskell/libxml-sax-0.7*:=[profile?]
+ >=dev-haskell/network-2.2.3:=[profile?]
+ >=dev-haskell/parsec-2.0:=[profile?]
+ <dev-haskell/parsec-3.2:=[profile?]
+ =dev-haskell/random-1.0*:=[profile?]
+ >=dev-haskell/text-0.11.1.5:=[profile?]
+ <dev-haskell/text-0.12:=[profile?]
+ >=dev-haskell/transformers-0.2:=[profile?]
+ <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/vector-0.7:=[profile?]
+ <dev-haskell/vector-0.11:=[profile?]
+ =dev-haskell/xml-types-0.3*:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
diff --git a/dev-haskell/dbus/metadata.xml b/dev-haskell/dbus/metadata.xml
new file mode 100644
index 000000000000..e0887ee78e85
--- /dev/null
+++ b/dev-haskell/dbus/metadata.xml
@@ -0,0 +1,60 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ D-Bus is a simple, message-based protocol for inter-process
+ communication, which allows applications to interact with other parts of
+ the machine and the user&#39;s session using remote procedure calls.
+
+ D-Bus is a essential part of the modern Linux desktop, where it replaces
+ earlier protocols such as CORBA and DCOP.
+
+ This library is an implementation of the D-Bus protocol in Haskell. It
+ can be used to add D-Bus support to Haskell applications, without the
+ awkward interfaces common to foreign bindings.
+
+ Example: connect to the session bus, and get a list of active names.
+
+ @
+ &amp;#x7b;-\# LANGUAGE OverloadedStrings \#-&amp;#x7d;
+
+ import Data.List (sort)
+ import DBus
+ import DBus.Client
+
+ main = do
+ &amp;#x20; client &lt;- connectSession
+ &amp;#x20; //
+ &amp;#x20; \-- Request a list of connected clients from the bus
+ &amp;#x20; reply &lt;- call_ client (methodCall \&quot;\/org\/freedesktop\/DBus\&quot; \&quot;org.freedesktop.DBus\&quot; \&quot;ListNames\&quot;)
+ &amp;#x20; &amp;#x7b; methodCallDestination = Just \&quot;org.freedesktop.DBus\&quot;
+ &amp;#x20; &amp;#x7d;
+ &amp;#x20; //
+ &amp;#x20; \-- org.freedesktop.DBus.ListNames() returns a single value, which is
+ &amp;#x20; \-- a list of names (here represented as [String])
+ &amp;#x20; let Just names = fromVariant (methodReturnBody reply !! 0)
+ &amp;#x20; //
+ &amp;#x20; \-- Print each name on a line, sorted so reserved names are below
+ &amp;#x20; \-- temporary names.
+ &amp;#x20; mapM_ putStrLn (sort names)
+ @
+
+ &gt;$ ghc --make list-names.hs
+ &gt;$ ./list-names
+ &gt;:1.0
+ &gt;:1.1
+ &gt;:1.10
+ &gt;:1.106
+ &gt;:1.109
+ &gt;:1.110
+ &gt;ca.desrt.dconf
+ &gt;org.freedesktop.DBus
+ &gt;org.freedesktop.Notifications
+ &gt;org.freedesktop.secrets
+ &gt;org.gnome.ScreenSaver
+ </longdescription>
+</pkgmetadata>