summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-07-27 18:33:49 +0000
committerJustin Lecher <jlec@gentoo.org>2015-07-27 18:33:49 +0000
commit92a44108ae63cc88a9769627f18dfcf899610556 (patch)
treeaaa548bee40cb390cb58f5f7707e753bdcae028c /dev-dotnet
parentDrop old (diff)
downloadgentoo-2-92a44108ae63cc88a9769627f18dfcf899610556.tar.gz
gentoo-2-92a44108ae63cc88a9769627f18dfcf899610556.tar.bz2
gentoo-2-92a44108ae63cc88a9769627f18dfcf899610556.zip
Backport patch, bug #537548; thanks Jason Lynch preparing the patch; Bump to mono-env.eclass and EAPI=5
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/zeitgeist-sharp/ChangeLog10
-rw-r--r--dev-dotnet/zeitgeist-sharp/files/zeitgeist-sharp-0.8.0.0-fix-tools-version.patch10
-rw-r--r--dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0-r2.ebuild52
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-dotnet/zeitgeist-sharp/ChangeLog b/dev-dotnet/zeitgeist-sharp/ChangeLog
index 81ce505f3eac..5830f1ff7fbc 100644
--- a/dev-dotnet/zeitgeist-sharp/ChangeLog
+++ b/dev-dotnet/zeitgeist-sharp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-dotnet/zeitgeist-sharp
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/zeitgeist-sharp/ChangeLog,v 1.10 2015/07/27 18:27:45 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/zeitgeist-sharp/ChangeLog,v 1.11 2015/07/27 18:33:49 jlec Exp $
+
+*zeitgeist-sharp-0.8.0.0-r2 (27 Jul 2015)
+
+ 27 Jul 2015; Justin Lecher <jlec@gentoo.org>
+ +files/zeitgeist-sharp-0.8.0.0-fix-tools-version.patch,
+ +zeitgeist-sharp-0.8.0.0-r2.ebuild:
+ Backport patch, bug #537548; thanks Jason Lynch preparing the patch; Bump to
+ mono-env.eclass and EAPI=5
27 Jul 2015; Justin Lecher <jlec@gentoo.org> -zeitgeist-sharp-0.8.0.0.ebuild:
Drop old
diff --git a/dev-dotnet/zeitgeist-sharp/files/zeitgeist-sharp-0.8.0.0-fix-tools-version.patch b/dev-dotnet/zeitgeist-sharp/files/zeitgeist-sharp-0.8.0.0-fix-tools-version.patch
new file mode 100644
index 000000000000..825b16b2d3b5
--- /dev/null
+++ b/dev-dotnet/zeitgeist-sharp/files/zeitgeist-sharp-0.8.0.0-fix-tools-version.patch
@@ -0,0 +1,10 @@
+diff -ur a/Zeitgeist/Zeitgeist.csproj b/Zeitgeist/Zeitgeist.csproj
+--- a/Zeitgeist/Zeitgeist.csproj 2011-05-09 16:24:12.000000000 -0500
++++ b/Zeitgeist/Zeitgeist.csproj 2015-02-25 11:13:13.360309437 -0600
+@@ -1,5 +1,5 @@
+ <?xml version="1.0" encoding="utf-8"?>
+-<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003">
++<Project DefaultTargets="Build" xmlns="http://schemas.microsoft.com/developer/msbuild/2003" ToolsVersion="4.0">
+ <PropertyGroup>
+ <Configuration Condition=" '$(Configuration)' == '' ">Debug</Configuration>
+ <Platform Condition=" '$(Platform)' == '' ">AnyCPU</Platform>
diff --git a/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0-r2.ebuild b/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0-r2.ebuild
new file mode 100644
index 000000000000..b79ee62183e5
--- /dev/null
+++ b/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/zeitgeist-sharp/zeitgeist-sharp-0.8.0.0-r2.ebuild,v 1.1 2015/07/27 18:33:49 jlec Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils mono-env versionator
+
+DIR_PV=$(get_version_component_range 1-2)
+DIR_PV2=$(get_version_component_range 1-3)
+
+DESCRIPTION="Mono DBus API wrapper for Zeitgeist"
+HOMEPAGE="https://launchpad.net/zeitgeist-sharp/"
+SRC_URI="
+ http://launchpad.net/zeitgeist-sharp/${DIR_PV}/${DIR_PV2}/+download/${P}.tar.gz
+ doc? ( http://launchpad.net/zeitgeist-sharp/${DIR_PV}/${DIR_PV2}/+download/${PN}-docs-${DIR_PV2}.tar.gz )"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="doc"
+
+RDEPEND="
+ dev-dotnet/dbus-sharp
+ dev-dotnet/dbus-sharp-glib
+ dev-dotnet/glib-sharp
+ dev-lang/mono
+ gnome-extra/zeitgeist"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${P}-zg-0.9.patch
+ "${FILESDIR}"/${P}-automake-1.12.patch
+ "${FILESDIR}"/${P}-fix-tools-version.patch
+)
+
+src_prepare() {
+ sed \
+ -e "s:@expanded_libdir@:@libdir@:" \
+ -i Zeitgeist/zeitgeist-sharp.pc.in || die
+ autotools-utils_src_prepare
+}
+
+src_install() {
+ use doc && HTML_DOCS=( "${WORKDIR}"/${PN}-docs/. )
+ autotools-utils_src_install
+}