summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-05-31 08:25:49 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-05-31 08:25:49 +0000
commitdfda3a0a28f3786027f8a5e2fee5c77940d769fb (patch)
tree6894855a83c5017811c5d135bcc6a75a0d165b1f /app-sci/xephem
parentupdated gpm to r2 trying to fix libsvga bug (diff)
downloadgentoo-2-dfda3a0a28f3786027f8a5e2fee5c77940d769fb.tar.gz
gentoo-2-dfda3a0a28f3786027f8a5e2fee5c77940d769fb.tar.bz2
gentoo-2-dfda3a0a28f3786027f8a5e2fee5c77940d769fb.zip
New package. Fixes #3055
Diffstat (limited to 'app-sci/xephem')
-rw-r--r--app-sci/xephem/ChangeLog14
-rw-r--r--app-sci/xephem/files/digest-xephem-3.5.20
-rw-r--r--app-sci/xephem/xephem-3.5.2.ebuild55
3 files changed, 69 insertions, 0 deletions
diff --git a/app-sci/xephem/ChangeLog b/app-sci/xephem/ChangeLog
new file mode 100644
index 000000000000..30ce39f09891
--- /dev/null
+++ b/app-sci/xephem/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for app-sci/xephem
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xephem/ChangeLog,v 1.1 2002/05/31 08:25:49 rphillips Exp $
+
+*xephem-3.5.2 (31 May 2002)
+
+ 31 May 2002; Ryan Phillips <rphillips@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
+
diff --git a/app-sci/xephem/files/digest-xephem-3.5.2 b/app-sci/xephem/files/digest-xephem-3.5.2
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-sci/xephem/files/digest-xephem-3.5.2
diff --git a/app-sci/xephem/xephem-3.5.2.ebuild b/app-sci/xephem/xephem-3.5.2.ebuild
new file mode 100644
index 000000000000..28ca71b93434
--- /dev/null
+++ b/app-sci/xephem/xephem-3.5.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# Author: Dimitri Aivaliotis <dimitri@aivaliotis.org>
+# $Header: /var/cvsroot/gentoo-x86/app-sci/xephem/xephem-3.5.2.ebuild,v 1.1 2002/05/31 08:25:49 rphillips Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XEphem is the X Windows Ephemeris, and provides a scientific-grade solar system model, star charts, sky views, plus a whole lot more."
+SRC_URI=""
+HOMEPAGE="http://www.clearskyinstitute.com/xephem"
+DEPEND="x11-libs/openmotif"
+
+pkg_setup() {
+ if [ ! -f ${DISTDIR}/${P}.tar.gz ] ; then
+ die "Please download ${P}.tar.gz from ${HOMEPAGE} and move it to ${DISTDIR}"
+ fi
+}
+
+src_unpack() {
+ unpack ${P}.tar.gz
+}
+
+src_compile() {
+
+ cd libastro
+ emake || die
+ cd ../libip
+ emake || die
+ cd ../GUI/xephem
+ xmkmf
+ emake || die
+
+}
+
+src_install() {
+
+ into /usr
+ dobin ${S}/GUI/xephem/xephem
+ insinto /opt/xephem/auxil
+ doins ${S}/GUI/xephem/auxil/*
+ insinto /opt/xephem/catalogs
+ doins ${S}/GUI/xephem/catalogs/*
+ insinto /opt/xephem/fifos
+ doins ${S}/GUI/xephem/fifos/*
+ insinto /opt/xephem/fits
+ doins ${S}/GUI/xephem/fits/*
+
+ cat > ${S}/XEphem <<EOT
+XEphem.ShareDir: /opt/xephem
+EOT
+ insinto /usr/lib/X11/app-defaults/
+ doins ${S}/XEphem
+
+ dodoc Copyright README
+
+}