summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-09 08:44:08 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-09 08:44:08 +0000
commitc2516fc61fe7917ac79490b0505e5f45ffc3830a (patch)
tree56a5cfd443e689da0e32a89a4d476e1918b95956 /app-office/qtstalker
parentRemove stale libtool macros from local m4 files #220819 by Paul Hartman. (diff)
downloadgentoo-2-c2516fc61fe7917ac79490b0505e5f45ffc3830a.tar.gz
gentoo-2-c2516fc61fe7917ac79490b0505e5f45ffc3830a.tar.bz2
gentoo-2-c2516fc61fe7917ac79490b0505e5f45ffc3830a.zip
Add patch for gcc-4.3.0, remove old. Closes bug #217671.
(Portage version: 2.1.5.4)
Diffstat (limited to 'app-office/qtstalker')
-rw-r--r--app-office/qtstalker/files/qtstalker-0.33-install_docs_with_emerge.patch9
-rw-r--r--app-office/qtstalker/files/qtstalker-0.33-sandboxfix_no_fixpath.patch22
-rw-r--r--app-office/qtstalker/files/qtstalker-0.35-gcc43.patch29
-rw-r--r--app-office/qtstalker/files/qtstalker-install_docs_with_emerge.patch9
-rw-r--r--app-office/qtstalker/files/qtstalker-no_mysql_support.patch20
-rw-r--r--app-office/qtstalker/files/qtstalker-sandboxfix_no_fixpath.patch33
-rw-r--r--app-office/qtstalker/qtstalker-0.32.ebuild78
-rw-r--r--app-office/qtstalker/qtstalker-0.33.ebuild88
-rw-r--r--app-office/qtstalker/qtstalker-0.35.ebuild3
9 files changed, 31 insertions, 260 deletions
diff --git a/app-office/qtstalker/files/qtstalker-0.33-install_docs_with_emerge.patch b/app-office/qtstalker/files/qtstalker-0.33-install_docs_with_emerge.patch
deleted file mode 100644
index 69f52a89d968..000000000000
--- a/app-office/qtstalker/files/qtstalker-0.33-install_docs_with_emerge.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -Naur qtstalker-orig/qtstalker.pro qtstalker/qtstalker.pro
---- qtstalker-orig/qtstalker.pro 2006-09-25 17:21:13.000000000 +0200
-+++ qtstalker/qtstalker.pro 2007-03-01 20:19:07.000000000 +0100
-@@ -30,5 +30,3 @@
- SUBDIRS += plugins/indicator/VIDYA
- SUBDIRS += plugins/indicator/VOL
- SUBDIRS += plugins/indicator/VOLA
--
--SUBDIRS += docs
diff --git a/app-office/qtstalker/files/qtstalker-0.33-sandboxfix_no_fixpath.patch b/app-office/qtstalker/files/qtstalker-0.33-sandboxfix_no_fixpath.patch
deleted file mode 100644
index 277b1b31fc59..000000000000
--- a/app-office/qtstalker/files/qtstalker-0.33-sandboxfix_no_fixpath.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-diff -Naur qtstalker-orig/plugin.config qtstalker/plugin.config
---- qtstalker-orig/plugin.config 2005-05-22 18:33:27.000000000 +0000
-+++ qtstalker/plugin.config 2005-10-11 20:13:08.000000000 +0000
-@@ -1,6 +1,6 @@
- TEMPLATE = lib
-
--CONFIG += thread warn_on plugin
-+CONFIG += thread warn_on plugin no_fixpath
-
- QMAKE_CXXFLAGS += -ffast-math -Os
-
-diff -Naur qtstalker-orig/lib/lib.pro qtstalker/lib/lib.pro
---- qtstalker-orig/lib/lib.pro 2005-05-22 18:33:28.000000000 +0000
-+++ qtstalker/lib/lib.pro 2006-09-28 22:37:28.000000000 +0000
-@@ -1,6 +1,6 @@
- TEMPLATE = lib
-
--CONFIG += thread warn_on
-+CONFIG += thread warn_on no_fixpath
-
- QMAKE_CXXFLAGS += -ffast-math -Os
-
diff --git a/app-office/qtstalker/files/qtstalker-0.35-gcc43.patch b/app-office/qtstalker/files/qtstalker-0.35-gcc43.patch
new file mode 100644
index 000000000000..c42b58578833
--- /dev/null
+++ b/app-office/qtstalker/files/qtstalker-0.35-gcc43.patch
@@ -0,0 +1,29 @@
+--- qtstalker/lib/UpgradeMessage.cpp.orig 2008-04-14 17:59:26.000000000 +0200
++++ qtstalker/lib/UpgradeMessage.cpp 2008-04-14 17:59:59.000000000 +0200
+@@ -32,10 +32,11 @@
+ #include <qfileinfo.h>
+ #include <qdir.h>
+ #include <qfile.h>
+ #include <qpushbutton.h>
+ #include <db.h>
++#include <stdlib.h>
+
+ UpgradeMessage::UpgradeMessage (int type) : QTabDialog (0, "UpgradeMessage", TRUE)
+ {
+ switch (type)
+ {
+--- qtstalker/src/IndicatorPage.cpp.orig 2008-04-14 18:06:35.000000000 +0200
++++ qtstalker/src/IndicatorPage.cpp 2008-04-14 18:07:01.000000000 +0200
+@@ -41,11 +41,11 @@
+ #include <qfile.h>
+ #include <qtextstream.h>
+ #include <qinputdialog.h>
+ #include <qmessagebox.h>
+ #include <qtooltip.h>
+-
++#include <stdlib.h>
+
+ IndicatorPage::IndicatorPage (QWidget *w, DBIndex *i) : QWidget (w)
+ {
+ chartIndex = i;
+ updateEnableFlag = FALSE;
diff --git a/app-office/qtstalker/files/qtstalker-install_docs_with_emerge.patch b/app-office/qtstalker/files/qtstalker-install_docs_with_emerge.patch
deleted file mode 100644
index 989062eb1834..000000000000
--- a/app-office/qtstalker/files/qtstalker-install_docs_with_emerge.patch
+++ /dev/null
@@ -1,9 +0,0 @@
-diff -Naur qtstalker-orig/qtstalker.pro qtstalker/qtstalker.pro
---- qtstalker-orig/qtstalker.pro 2005-10-11 20:43:45.000000000 +0000
-+++ qtstalker/qtstalker.pro 2005-10-11 20:56:34.000000000 +0000
-@@ -80,5 +80,3 @@
- SUBDIRS += plugins/co/TrendLine
- SUBDIRS += plugins/co/FiboLine
- SUBDIRS += plugins/co/Cycle
--
--SUBDIRS += docs
diff --git a/app-office/qtstalker/files/qtstalker-no_mysql_support.patch b/app-office/qtstalker/files/qtstalker-no_mysql_support.patch
deleted file mode 100644
index 0b86107997d2..000000000000
--- a/app-office/qtstalker/files/qtstalker-no_mysql_support.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Naur qtstalker-orig/qtstalker.pro qtstalker/qtstalker.pro
---- qtstalker-orig/qtstalker.pro 2005-06-02 21:50:56.000000000 +0000
-+++ qtstalker/qtstalker.pro 2005-10-11 20:16:28.000000000 +0000
-@@ -21,16 +21,6 @@
- SUBDIRS += plugins/quote/QtstalkerFormat
- SUBDIRS += plugins/quote/Yahoo
-
--#linux: conditional compile if user has mysql installed
--unix:linux-g++:exists(/usr/include/mysql/mysql.h){
-- SUBDIRS += plugins/quote/MySQL
--}
--
--#freebsd: conditional compile if user has mysql installed
--unix:freebsd-g++:exists(/usr/local/include/mysql/mysql.h){
-- SUBDIRS += plugins/quote/MySQL
--}
--
- #compile indicator plugins
- SUBDIRS += plugins/indicator/AD
- SUBDIRS += plugins/indicator/AdaptSTOCH
diff --git a/app-office/qtstalker/files/qtstalker-sandboxfix_no_fixpath.patch b/app-office/qtstalker/files/qtstalker-sandboxfix_no_fixpath.patch
deleted file mode 100644
index 01da3dfa98c4..000000000000
--- a/app-office/qtstalker/files/qtstalker-sandboxfix_no_fixpath.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Naur qtstalker-orig/src/src.pro qtstalker/src/src.pro
---- qtstalker-orig/src/src.pro 2005-06-05 17:35:14.000000000 +0000
-+++ qtstalker/src/src.pro 2005-10-11 19:26:54.000000000 +0000
-@@ -1,6 +1,6 @@
- TEMPLATE = app
-
--CONFIG += thread warn_on debug
-+CONFIG += thread warn_on debug no_fixpath
-
- QMAKE_CXXFLAGS += -rdynamic -ffast-math
- QMAKE_CXXFLAGS += -Os
-diff -Naur qtstalker-orig/plugin.config qtstalker/plugin.config
---- qtstalker-orig/plugin.config 2005-05-22 18:33:27.000000000 +0000
-+++ qtstalker/plugin.config 2005-10-11 20:13:08.000000000 +0000
-@@ -1,6 +1,6 @@
- TEMPLATE = lib
-
--CONFIG += thread warn_on plugin
-+CONFIG += thread warn_on plugin no_fixpath
-
- QMAKE_CXXFLAGS += -ffast-math -Os
-
-diff -Naur qtstalker-orig/lib/lib.pro qtstalker/lib/lib.pro
---- qtstalker-orig/lib/lib.pro 2005-05-22 18:33:28.000000000 +0000
-+++ qtstalker/lib/lib.pro 2006-09-28 22:37:28.000000000 +0000
-@@ -1,6 +1,6 @@
- TEMPLATE = lib
-
--CONFIG += thread warn_on
-+CONFIG += thread warn_on no_fixpath
-
- QMAKE_CXXFLAGS += -ffast-math -Os
-
diff --git a/app-office/qtstalker/qtstalker-0.32.ebuild b/app-office/qtstalker/qtstalker-0.32.ebuild
deleted file mode 100644
index 75c7e42c2fa3..000000000000
--- a/app-office/qtstalker/qtstalker-0.32.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/qtstalker/qtstalker-0.32.ebuild,v 1.4 2008/03/14 14:23:55 phreak Exp $
-
-inherit qt3 eutils
-
-IUSE="mysql"
-LANGS="pl"
-for i in ${LNAGS}; do
- IUSE="${IUSE} linguas_${i}"
-done
-
-DESCRIPTION="Commodity and stock market charting and technical analysis"
-HOMEPAGE="http://qtstalker.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-
-DEPEND="$(qt_min_version 3.3)
- mysql? ( dev-db/mysql )"
-
-S="${WORKDIR}/${PN}"
-
-# linking erros about missing lqtstalker lib when -jX
-# from MAKEOPTS is being set to anything higher than -j1
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-sandboxfix_no_fixpath.patch
- epatch "${FILESDIR}"/${PN}-install_docs_with_emerge.patch
- # without that, qtstalker will use mysql, when only it is installed,
- # even when we do not want mysql support for this package
- ! use mysql && epatch "${FILESDIR}"/${PN}-no_mysql_support.patch
-}
-
-src_compile() {
- ${QTDIR}/bin/qmake ${PN}.pro \
- QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
- QMAKE_RPATH= \
- || die "qmake ${PN}.pro failed"
-
- cd "${S}"/lib
- ${QTDIR}/bin/qmake lib.pro \
- QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
- QMAKE_RPATH= \
- || die "qmake ${PN}.pro failed"
-
- cd "${S}"
- emake || die "make failed"
-}
-
-src_install() {
- # we have to export this...
- export INSTALL_ROOT="${D}"
- make install || die "make install failed"
-
- cd "${S}"/docs
- dohtml *{html,png}
- dodoc AUTHORS BUGS CHANGELOG INSTALL TODO "${S}"/README
-
- # install only needed langpacks
- cd "${S}"/i18n
- insinto /usr/share/${PN}/i18n
- for i in ${LINGUAS}; do
- if [ -f ${PN}_${i}.qm ]; then
- doins ${PN}_${i}.qm
- fi
- done
-
- # menu and icon
- domenu "${FILESDIR}"/${PN}.desktop
- doicon "${FILESDIR}"/${PN}.png
-}
diff --git a/app-office/qtstalker/qtstalker-0.33.ebuild b/app-office/qtstalker/qtstalker-0.33.ebuild
deleted file mode 100644
index 67e54ef8a58e..000000000000
--- a/app-office/qtstalker/qtstalker-0.33.ebuild
+++ /dev/null
@@ -1,88 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/qtstalker/qtstalker-0.33.ebuild,v 1.2 2008/03/14 14:23:55 phreak Exp $
-
-inherit qt3 eutils
-
-IUSE=""
-LANGS="pl"
-for i in ${LNAGS}; do
- IUSE="${IUSE} linguas_${i}"
-done
-
-DESCRIPTION="Commodity and stock market charting and technical analysis"
-HOMEPAGE="http://qtstalker.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-
-DEPEND="$(qt_min_version 3.3)
- >=sys-libs/db-4"
-
-S="${WORKDIR}/${PN}"
-
-# linking error about missing lqtstalker lib when using -jX
-MAKEOPTS="${MAKEOPTS} -j1"
-
-src_unpack() {
- unpack ${A}
-
- cd "${S}"
- epatch "${FILESDIR}"/${P}-sandboxfix_no_fixpath.patch
- epatch "${FILESDIR}"/${P}-install_docs_with_emerge.patch
-}
-
-src_compile() {
- # some Qt4 problems...
- einfo "Proccessing qmake with .pro files..."
- PROS="${S}/src/src.pro ${S}/lib/lib.pro ${S}/${PN}.pro `find ${S}/plugins -name \"*.pro\"`"
- for i in ${PROS}; do
- pdir="`echo ${i} | sed -e 's/\/[a-zA-Z]*.pro$//'`"
- pfile="`echo ${i} | sed -e 's/^.*\///'`"
-
- cd "${pdir}"
- ${QTDIR}/bin/qmake ${pfile} \
- QMAKE_CXXFLAGS_RELEASE="${CXXFLAGS}" \
- QMAKE_RPATH= \
- QMAKE=/usr/bin/qmake \
- QMAKE_RPATH= \
- || die "qmake ${pfile} failed"
- done
-
- cd "${S}"
- emake || die "make failed"
-
- einfo "Building langpaccks..."
- for i in ${LINGUAS}; do
- if [ -f ${PN}_${i}.ts ]; then
- lrelease ${PN}_${i}.ts
- fi
- done
-}
-
-src_install() {
- # we have to export this...
- export INSTALL_ROOT="${D}"
- make install || die "make install failed"
-
- einfo "Installing docs..."
- cd "${S}"/docs
- dohtml *{html,png}
- dodoc AUTHORS BUGS CHANGELOG INSTALL TODO "${S}"/README
-
- # install only needed langpacks
- einfo "Installing langpacks..."
- cd "${S}"/i18n
- insinto /usr/share/${PN}/i18n
- for i in ${LINGUAS}; do
- if [ -f ${PN}_${i}.qm ]; then
- doins ${PN}_${i}.qm
- fi
- done
-
- # menu and icon
- domenu "${FILESDIR}"/${PN}.desktop
- doicon "${FILESDIR}"/${PN}.png
-}
diff --git a/app-office/qtstalker/qtstalker-0.35.ebuild b/app-office/qtstalker/qtstalker-0.35.ebuild
index 760340d3099f..73a0202de09e 100644
--- a/app-office/qtstalker/qtstalker-0.35.ebuild
+++ b/app-office/qtstalker/qtstalker-0.35.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/qtstalker/qtstalker-0.35.ebuild,v 1.2 2008/01/20 09:44:17 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/qtstalker/qtstalker-0.35.ebuild,v 1.3 2008/06/09 08:44:07 loki_val Exp $
inherit qt3 eutils multilib
@@ -31,6 +31,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-nodocs.patch
epatch "${FILESDIR}"/${P}-parallel-make.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
ebegin 'Fixing install paths'
grep -rl '/usr/local' * \