summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2012-11-25 15:36:23 +0000
committerSebastian Pipping <sping@gentoo.org>2012-11-25 15:36:23 +0000
commit9c941cafa2c011ef0b0060acc150e95c8abdc1f1 (patch)
treee0cface818632a386f56611333cf421ddc169c85 /app-mobilephone
parentSupport user LDFLAGS, bug #332479. (diff)
downloadgentoo-2-9c941cafa2c011ef0b0060acc150e95c8abdc1f1.tar.gz
gentoo-2-9c941cafa2c011ef0b0060acc150e95c8abdc1f1.tar.bz2
gentoo-2-9c941cafa2c011ef0b0060acc150e95c8abdc1f1.zip
app-mobilephone/wammu: 0.36 (bug #388353)
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'app-mobilephone')
-rw-r--r--app-mobilephone/wammu/ChangeLog9
-rw-r--r--app-mobilephone/wammu/wammu-0.36.ebuild66
2 files changed, 73 insertions, 2 deletions
diff --git a/app-mobilephone/wammu/ChangeLog b/app-mobilephone/wammu/ChangeLog
index 1ef0dd5a6e56..577323f38fe1 100644
--- a/app-mobilephone/wammu/ChangeLog
+++ b/app-mobilephone/wammu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-mobilephone/wammu
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.51 2011/08/13 07:15:07 xarthisius Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/ChangeLog,v 1.52 2012/11/25 15:36:23 sping Exp $
+
+*wammu-0.36 (25 Nov 2012)
+
+ 25 Nov 2012; Sebastian Pipping <sping@gentoo.org> +wammu-0.36.ebuild:
+ Bump to 0.36, looks trivial (bug #388353)
13 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org> wammu-0.30.1.ebuild,
wammu-0.34.ebuild, wammu-0.35.ebuild:
diff --git a/app-mobilephone/wammu/wammu-0.36.ebuild b/app-mobilephone/wammu/wammu-0.36.ebuild
new file mode 100644
index 000000000000..9f797d6826a9
--- /dev/null
+++ b/app-mobilephone/wammu/wammu-0.36.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/wammu/wammu-0.36.ebuild,v 1.1 2012/11/25 15:36:23 sping Exp $
+
+EAPI="3"
+
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Front-end for gammu to access mobile phones easily"
+HOMEPAGE="http://www.wammu.eu/"
+SRC_URI="http://dl.cihar.com/wammu/v0/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth gnome"
+
+RDEPEND=">=app-mobilephone/gammu-1.25.0[python]
+ >=dev-python/wxpython-2.8
+ bluetooth? ( dev-python/pybluez
+ gnome? ( net-wireless/gnome-bluetooth )
+ )"
+DEPEND="${RDEPEND}"
+
+# Supported languages and translated documentation
+# Be sure all languages are prefixed with a single space!
+MY_AVAILABLE_LINGUAS=" af bg ca cs da de el es et fi fr gl he hu id it ko nl pl pt_BR ru sk sv zh_CN zh_TW"
+IUSE="${IUSE} ${MY_AVAILABLE_LINGUAS// / linguas_}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ local lang support_linguas=no
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if use linguas_${lang} ; then
+ support_linguas=yes
+ break
+ fi
+ done
+ # install all languages when all selected LINGUAS aren't supported
+ if [ "${support_linguas}" = "yes" ]; then
+ for lang in ${MY_AVAILABLE_LINGUAS} ; do
+ if ! use linguas_${lang} ; then
+ rm -r locale/${lang} || die
+ fi
+ done
+ fi
+
+ python_convert_shebangs -r 2 .
+}
+
+src_compile() {
+ # SKIPWXCHECK: else 'import wx' results in
+ # Xlib: connection to ":0.0" refused by server
+ SKIPWXCHECK=yes distutils_src_compile
+}
+
+src_install() {
+ DOCS="AUTHORS FAQ"
+ SKIPWXCHECK=yes distutils_src_install
+}