summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-07-13 07:40:32 +0000
committerMike Frysinger <vapier@gentoo.org>2003-07-13 07:40:32 +0000
commit0fc0922d0f005a6e9af5f0cf29b46072cde51965 (patch)
treea1aabfa057950bf27b23d3377bfd8dc109f3a37b /app-emulation/vice
parentUpdated version. See ChangeLog for needed kernel support details. (diff)
downloadgentoo-2-0fc0922d0f005a6e9af5f0cf29b46072cde51965.tar.gz
gentoo-2-0fc0922d0f005a6e9af5f0cf29b46072cde51965.tar.bz2
gentoo-2-0fc0922d0f005a6e9af5f0cf29b46072cde51965.zip
nls support fix #24041 + games.eclass
Diffstat (limited to 'app-emulation/vice')
-rw-r--r--app-emulation/vice/Manifest9
-rw-r--r--app-emulation/vice/vice-1.12-r1.ebuild55
2 files changed, 60 insertions, 4 deletions
diff --git a/app-emulation/vice/Manifest b/app-emulation/vice/Manifest
index 751d418a0294..4a42c38ad40e 100644
--- a/app-emulation/vice/Manifest
+++ b/app-emulation/vice/Manifest
@@ -1,5 +1,6 @@
-MD5 385fbfc77c3a5814770f9b5abd28c171 ChangeLog 763
-MD5 9493796d7927b933662bc68637fb1c7e vice-1.12.ebuild 1324
-MD5 9e902858f9beeebb848e11f1f9eaa63b vice-1.11.ebuild 1323
MD5 6b44b25bb31dd21195c5bb6ac016d49d files/digest-vice-1.12 62
-MD5 a5dd12faf8edd8012553753de04c0a2d files/digest-vice-1.11 62
+MD5 bee1c24b1742b33f95f243358383697e files/1.12-po-Makefile.patch 555
+MD5 6b44b25bb31dd21195c5bb6ac016d49d files/digest-vice-1.12-r1 62
+MD5 9493796d7927b933662bc68637fb1c7e vice-1.12.ebuild 1324
+MD5 4a596b207c8313ab1add96f3e75509c4 ChangeLog 937
+MD5 2d67e5e861a63fa88799c01cafc5d4f1 vice-1.12-r1.ebuild 1278
diff --git a/app-emulation/vice/vice-1.12-r1.ebuild b/app-emulation/vice/vice-1.12-r1.ebuild
new file mode 100644
index 000000000000..44e213352dc4
--- /dev/null
+++ b/app-emulation/vice/vice-1.12-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-1.12-r1.ebuild,v 1.1 2003/07/13 07:40:14 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="The Versatile Commodore 8-bit Emulator"
+HOMEPAGE="http://viceteam.bei.t-online.de/"
+SRC_URI="ftp://ftp.funet.fi/pub/cbm/crossplatform/emulators/VICE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE="sdl nls gnome arts"
+
+DEPEND=">=x11-base/xfree-4.0
+ sdl? ( media-libs/libsdl )
+ gnome? ( gnome-base/libgnomeui )
+ arts? ( kde-base/arts )"
+
+src_unpack() {
+ unpack ${A}
+ if [ `use nls` ] ; then
+ cd ${S}/po
+ epatch ${FILESDIR}/${PV}-po-Makefile.patch
+ else
+ cd ${S}
+ sed -i '/^SUBDIRS =/s:po::' Makefile.in
+ fi
+}
+
+src_compile() {
+ egamesconf \
+ --enable-fullscreen \
+ `use_with sdl` \
+ `use_with gnome gnomeui` \
+ `use_with arts` \
+ `use_enable nls` \
+ || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ dohtml ${D}/usr/lib/vice/doc/*.html
+ dodoc \
+ ${D}/usr/lib/vice/doc/NLS-Howto.txt \
+ ${D}/usr/lib/vice/doc/Readme.beos \
+ ${D}/usr/lib/vice/doc/Readme.dos \
+ ${D}/usr/lib/vice/doc/Win32-Howto.txt \
+ ${D}/usr/lib/vice/doc/mon.txt
+
+ rm ${D}/usr/lib/vice/doc -rf
+}