summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-09-10 13:07:39 +0000
committerUlrich Müller <ulm@gentoo.org>2009-09-10 13:07:39 +0000
commit349b4399dce86fa9e1a9c6f9340468c01edb6eb7 (patch)
treea1734f41c6209310d1c20251353017a2e7b46d13 /app-emacs/chess
parentVersion bump to 2.6.31 and removal of all 31_rc (diff)
downloadgentoo-2-349b4399dce86fa9e1a9c6f9340468c01edb6eb7.tar.gz
gentoo-2-349b4399dce86fa9e1a9c6f9340468c01edb6eb7.tar.bz2
gentoo-2-349b4399dce86fa9e1a9c6f9340468c01edb6eb7.zip
Install sounds and pixmaps for pieces under SITEETC.
(Portage version: 2.2_rc40/cvs/Linux i686)
Diffstat (limited to 'app-emacs/chess')
-rw-r--r--app-emacs/chess/ChangeLog9
-rw-r--r--app-emacs/chess/chess-2.0_beta6-r1.ebuild4
-rw-r--r--app-emacs/chess/chess-2.0_beta6-r2.ebuild40
-rw-r--r--app-emacs/chess/files/50chess-gentoo-2.0_beta6.el33
-rw-r--r--app-emacs/chess/files/50chess-gentoo.el7
5 files changed, 85 insertions, 8 deletions
diff --git a/app-emacs/chess/ChangeLog b/app-emacs/chess/ChangeLog
index 3f13afeb1156..5b65205a708a 100644
--- a/app-emacs/chess/ChangeLog
+++ b/app-emacs/chess/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-emacs/chess
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/ChangeLog,v 1.28 2009/03/29 21:23:38 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/ChangeLog,v 1.29 2009/09/10 13:07:37 ulm Exp $
+
+*chess-2.0_beta6-r2 (10 Sep 2009)
+
+ 10 Sep 2009; Ulrich Mueller <ulm@gentoo.org> chess-2.0_beta6-r1.ebuild,
+ +chess-2.0_beta6-r2.ebuild, +files/50chess-gentoo-2.0_beta6.el,
+ files/50chess-gentoo.el:
+ Install sounds and pixmaps for pieces under SITEETC.
29 Mar 2009; Ulrich Mueller <ulm@gentoo.org> chess-2.0_beta6-r1.ebuild:
Use autopatch feature of elisp.eclass.
diff --git a/app-emacs/chess/chess-2.0_beta6-r1.ebuild b/app-emacs/chess/chess-2.0_beta6-r1.ebuild
index f5ec7cfa7d41..ddba6cb80e4b 100644
--- a/app-emacs/chess/chess-2.0_beta6-r1.ebuild
+++ b/app-emacs/chess/chess-2.0_beta6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta6-r1.ebuild,v 1.5 2009/03/29 21:23:38 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta6-r1.ebuild,v 1.6 2009/09/10 13:07:37 ulm Exp $
inherit elisp
@@ -25,7 +25,7 @@ S="${WORKDIR}/${PN}"
DOCS="ChangeLog EPD.txt PGN.txt PLAN README TODO"
ELISP_PATCHES="${PV}-chess-pos-move-gentoo.patch
${PV}-chess-common-handler-gentoo.patch"
-SITEFILE="50${PN}-gentoo.el"
+SITEFILE="50${PN}-gentoo-${PV}.el"
# this is needed; elisp.eclass redefines src_compile() from portage default
src_compile() {
diff --git a/app-emacs/chess/chess-2.0_beta6-r2.ebuild b/app-emacs/chess/chess-2.0_beta6-r2.ebuild
new file mode 100644
index 000000000000..615bcfd67926
--- /dev/null
+++ b/app-emacs/chess/chess-2.0_beta6-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta6-r2.ebuild,v 1.1 2009/09/10 13:07:37 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="A chess client and library for Emacs"
+HOMEPAGE="http://emacs-chess.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-chess/${P/_beta/b}.tar.gz
+ mirror://gentoo/emacs-chess-sounds-${PV%%_*}.tar.bz2
+ mirror://gentoo/emacs-chess-pieces-${PV%%_*}.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="|| ( games-board/gnuchess
+ games-board/crafty
+ games-board/phalanx
+ games-board/sjeng )"
+
+S="${WORKDIR}/${PN}"
+DOCS="ChangeLog EPD.txt PGN.txt PLAN README TODO"
+ELISP_PATCHES="${PV}-chess-pos-move-gentoo.patch
+ ${PV}-chess-common-handler-gentoo.patch"
+SITEFILE="50${PN}-gentoo.el"
+
+# this is needed; elisp.eclass redefines src_compile() from portage default
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ elisp_src_install
+ doinfo chess.info || die "doinfo failed"
+ insinto "${SITEETC}/${PN}"
+ doins -r "${WORKDIR}"/{sounds,pieces} || die "doins failed"
+}
diff --git a/app-emacs/chess/files/50chess-gentoo-2.0_beta6.el b/app-emacs/chess/files/50chess-gentoo-2.0_beta6.el
new file mode 100644
index 000000000000..d8566c780211
--- /dev/null
+++ b/app-emacs/chess/files/50chess-gentoo-2.0_beta6.el
@@ -0,0 +1,33 @@
+(add-to-list 'load-path "@SITELISP@")
+
+(autoload 'chess "chess"
+ "Start a game of chess, playing against ENGINE (a module name)." t)
+(defalias 'chess-session 'chess)
+(autoload 'chess-create-display "chess"
+ "Create a display, letting the user's customization decide the style.")
+(autoload 'chess-link "chess-link"
+ "Play out a game between two engines, and watch the progress." t)
+(autoload 'chess-pgn-read "chess-pgn"
+ "Read and display a PGN game after point." t)
+(autoload 'chess-pgn-mode "chess-pgn"
+ "A mode for editing chess PGN files." t)
+(defalias 'pgn-mode 'chess-pgn-mode)
+(autoload 'chess-puzzle "chess-puzzle"
+ "Pick a random puzzle from FILE, and solve it against the default engine." t)
+(autoload 'chess-fischer-random-position "chess-random"
+ "Generate a Fischer Random style position.")
+(autoload 'chess-tutorial "chess-tutorial"
+ "A simple chess training display." t)
+(autoload 'chess-ics "chess-ics"
+ "Connect to an Internet Chess Server." t)
+
+(add-to-list 'auto-mode-alist '("\\.pgn\\'" . chess-pgn-mode))
+
+(setq chess-images-directory "/usr/share/pixmaps/chess/xboard")
+(setq chess-sound-directory "/usr/share/sounds/chess")
+
+;; Change the order of the engine preference list to coincide with the order
+;; of our dependencies: games-board/gnuchess, crafty, phalanx, and sjeng.
+;; The user can override this using M-x customize-group RET chess RET
+(setq chess-default-engine
+ '(chess-gnuchess chess-crafty chess-phalanx chess-sjeng))
diff --git a/app-emacs/chess/files/50chess-gentoo.el b/app-emacs/chess/files/50chess-gentoo.el
index 57c569558387..3aee961e25bc 100644
--- a/app-emacs/chess/files/50chess-gentoo.el
+++ b/app-emacs/chess/files/50chess-gentoo.el
@@ -1,6 +1,3 @@
-
-;;; chess site-lisp configuration
-
(add-to-list 'load-path "@SITELISP@")
(autoload 'chess "chess"
@@ -26,8 +23,8 @@
(add-to-list 'auto-mode-alist '("\\.pgn\\'" . chess-pgn-mode))
-(setq chess-images-directory "/usr/share/pixmaps/chess/xboard")
-(setq chess-sound-directory "/usr/share/sounds/chess")
+(setq chess-images-directory "@SITEETC@/pieces/xboard")
+(setq chess-sound-directory "@SITEETC@/sounds")
;; Change the order of the engine preference list to coincide with the order
;; of our dependencies: games-board/gnuchess, crafty, phalanx, and sjeng.