summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Maitin-Shepard <jbms@gentoo.org>2003-12-12 03:46:59 +0000
committerJeremy Maitin-Shepard <jbms@gentoo.org>2003-12-12 03:46:59 +0000
commitfb245de8299ababbb4b26ffc7f9175a4af7fc2a5 (patch)
tree9f3183c8ef47170b9bd935cfeac41631cda3781b /app-editors/qemacs
parentIncluded a patch for the configure script so that the package compiles on GCC... (diff)
downloadgentoo-2-fb245de8299ababbb4b26ffc7f9175a4af7fc2a5.tar.gz
gentoo-2-fb245de8299ababbb4b26ffc7f9175a4af7fc2a5.tar.bz2
gentoo-2-fb245de8299ababbb4b26ffc7f9175a4af7fc2a5.zip
Included a patch for the configure script so that the package compiles on GCC 3.3.
Diffstat (limited to 'app-editors/qemacs')
-rw-r--r--app-editors/qemacs/ChangeLog6
-rw-r--r--app-editors/qemacs/Manifest4
-rw-r--r--app-editors/qemacs/files/qemacs-0.3.1-configure-gentoo.patch12
-rw-r--r--app-editors/qemacs/qemacs-0.3.1.ebuild11
4 files changed, 25 insertions, 8 deletions
diff --git a/app-editors/qemacs/ChangeLog b/app-editors/qemacs/ChangeLog
index c1571f874ada..cfd3c355fa6d 100644
--- a/app-editors/qemacs/ChangeLog
+++ b/app-editors/qemacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/qemacs
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.1 2003/05/11 09:38:18 mkennedy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/ChangeLog,v 1.2 2003/12/12 03:46:56 jbms Exp $
+
+ 11 Dec 2003; Jeremy Maitin-Shepard <jbms@gentoo.org> qemacs-0.3.1.ebuild:
+ The ebuild now patches the configure script so that the package
+ compiles on GCC 3.3. Resolves Bug #35632.
*qemacs-0.3.1 (11 May 2003)
diff --git a/app-editors/qemacs/Manifest b/app-editors/qemacs/Manifest
index 0890202f0e6e..da0ed606e344 100644
--- a/app-editors/qemacs/Manifest
+++ b/app-editors/qemacs/Manifest
@@ -1,5 +1,5 @@
-MD5 ba3d9db88ffac77b17f12e26b2f00a88 ChangeLog 682
-MD5 fe320cbfd738d305673c181223eae2cf qemacs-0.3.1.ebuild 1022
+MD5 77d906d9dbc2ce9aa49b201b26b99ae6 ChangeLog 678
+MD5 3d670034edf2422b98ac784ada8e1f3a qemacs-0.3.1.ebuild 1022
MD5 26f2791358b330724fe8dfa7a4dba22a files/qemacs-0.3.1-configure-gentoo.patch 496
MD5 a4c613ab493b62325669d8d1353c8b2e files/qemacs-Makefile-gentoo.patch 421
MD5 1bef560680eaab10f0524f228c5dc6eb files/digest-qemacs-0.3.1 64
diff --git a/app-editors/qemacs/files/qemacs-0.3.1-configure-gentoo.patch b/app-editors/qemacs/files/qemacs-0.3.1-configure-gentoo.patch
new file mode 100644
index 000000000000..c7c230941b2a
--- /dev/null
+++ b/app-editors/qemacs/files/qemacs-0.3.1-configure-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ur qemacs-0.3.1.orig/configure qemacs-0.3.1/configure
+--- qemacs-0.3.1.orig/configure 2003-12-11 22:24:37.607928696 -0500
++++ qemacs-0.3.1/configure 2003-12-11 22:27:07.656117904 -0500
+@@ -311,7 +311,7 @@
+ head $source_path/VERSION >>config.mak
+ echo "" >>config.mak
+ echo -n "#define QE_VERSION \"" >> $TMPH
+-head $source_path/VERSION >> $TMPH
++echo -n `head $source_path/VERSION` >> $TMPH
+ echo "\"" >> $TMPH
+ if test "$network" = "yes" ; then
+ echo "#define CONFIG_NETWORK 1" >> $TMPH
diff --git a/app-editors/qemacs/qemacs-0.3.1.ebuild b/app-editors/qemacs/qemacs-0.3.1.ebuild
index 51827062a210..e99e055e7c31 100644
--- a/app-editors/qemacs/qemacs-0.3.1.ebuild
+++ b/app-editors/qemacs/qemacs-0.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.3 2003/10/24 12:55:26 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/qemacs/qemacs-0.3.1.ebuild,v 1.4 2003/12/12 03:46:56 jbms Exp $
DESCRIPTION="QEmacs (for Quick Emacs) is a very small but powerful UNIX editor."
HOMEPAGE="http://fabrice.bellard.free.fr/qemacs/"
@@ -16,21 +16,22 @@ S=${WORKDIR}/${P}
src_unpack() {
unpack ${A}
- cd ${S} && epatch ${FILESDIR}/qemacs-Makefile-gentoo.patch
+ cd ${S}
+ epatch ${FILESDIR}/qemacs-Makefile-gentoo.patch
+ epatch ${FILESDIR}/qemacs-${PV}-configure-gentoo.patch
}
src_compile() {
local myconf
use X && myconf="--enable-x11" || myconf="--disable-x11"
use png && myconf="${myconf} --enable-png" || myconf="${myconf} --disable-png"
- ./configure ${myconf}
+ econf ${myconf}
emake || die
}
src_install() {
dodir /usr/bin
- make prefix=${D}/usr \
- install || die
+ einstall || die
doman qe.1
dodoc COPYING Changelog README TODO VERSION
dohtml *.html