summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2009-09-30 06:08:27 +0000
committerRyan Hill <dirtyepic@gentoo.org>2009-09-30 06:08:27 +0000
commit87e608b172cd5c2925fd38d143e2c93b249c665d (patch)
treebe85b03f22828be10f62959b9479542b2e8071d9 /app-doc
parentAdd ~amd64 (diff)
downloadgentoo-2-87e608b172cd5c2925fd38d143e2c93b249c665d.tar.gz
gentoo-2-87e608b172cd5c2925fd38d143e2c93b249c665d.tar.bz2
gentoo-2-87e608b172cd5c2925fd38d143e2c93b249c665d.zip
Version bump.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'app-doc')
-rw-r--r--app-doc/abs-guide/ChangeLog7
-rw-r--r--app-doc/abs-guide/abs-guide-6.1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/app-doc/abs-guide/ChangeLog b/app-doc/abs-guide/ChangeLog
index f7258d66e453..daa98a64706b 100644
--- a/app-doc/abs-guide/ChangeLog
+++ b/app-doc/abs-guide/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-doc/abs-guide
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-doc/abs-guide/ChangeLog,v 1.76 2009/09/27 20:03:15 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-doc/abs-guide/ChangeLog,v 1.77 2009/09/30 06:08:27 dirtyepic Exp $
+
+*abs-guide-6.1 (30 Sep 2009)
+
+ 30 Sep 2009; Ryan Hill <dirtyepic@gentoo.org> +abs-guide-6.1.ebuild:
+ Version bump.
27 Sep 2009; nixnut <nixnut@gentoo.org> abs-guide-6.0.ebuild:
ppc stable #286602
diff --git a/app-doc/abs-guide/abs-guide-6.1.ebuild b/app-doc/abs-guide/abs-guide-6.1.ebuild
new file mode 100644
index 000000000000..d82eca29be2e
--- /dev/null
+++ b/app-doc/abs-guide/abs-guide-6.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-doc/abs-guide/abs-guide-6.1.ebuild,v 1.1 2009/09/30 06:08:27 dirtyepic Exp $
+
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+
+DESCRIPTION="An advanced reference and a tutorial on bash shell scripting"
+HOMEPAGE="http://www.tldp.org/LDP/abs/html"
+
+# Upstream likes to update the tarball without changing the name.
+# - fetch http://bash.webofcrafts.net/abs-guide-latest.tar.bz2
+# rename to abs-guide-${PV}.tar.bz2
+# - fetch http://bash.webofcrafts.net/abs-guide.pdf
+# rename to abs-guide-${PV}.pdf
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ pdf? ( mirror://gentoo/${P}.pdf )"
+
+LICENSE="OPL"
+IUSE="pdf"
+SLOT="0"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/abs"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+ use pdf && cp "${DISTDIR}"/${P}.pdf "${S}"
+ cd "${S}"
+}
+
+src_install() {
+ dodir /usr/share/doc/${P} || die "dodir failed"
+ cp -R * "${D}"/usr/share/doc/${P} || die "cp failed"
+ use pdf && { cp ${P}.pdf "${D}"/usr/share/doc/${P} || die "pdf failed"; }
+}