summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-16 16:24:27 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-10-16 16:24:27 +0000
commitf3e8a7e3debf2ae9c7046c2737a17690c20edcd6 (patch)
tree49bcb705f86cdaf6390e734dfc3357fc1e36cc72 /app-crypt
parentDelete older ebuild. (diff)
downloadgentoo-2-f3e8a7e3debf2ae9c7046c2737a17690c20edcd6.tar.gz
gentoo-2-f3e8a7e3debf2ae9c7046c2737a17690c20edcd6.tar.bz2
gentoo-2-f3e8a7e3debf2ae9c7046c2737a17690c20edcd6.zip
Version bump.
(Portage version: 2.2_rc97_p1/cvs/Linux x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/bcwipe/ChangeLog9
-rw-r--r--app-crypt/bcwipe/bcwipe-1.9.7.ebuild48
-rw-r--r--app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch20
3 files changed, 76 insertions, 1 deletions
diff --git a/app-crypt/bcwipe/ChangeLog b/app-crypt/bcwipe/ChangeLog
index 3bc2573849d1..e84a9390848b 100644
--- a/app-crypt/bcwipe/ChangeLog
+++ b/app-crypt/bcwipe/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/bcwipe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.43 2010/10/15 18:27:07 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/ChangeLog,v 1.44 2010/10/16 16:24:27 arfrever Exp $
+
+*bcwipe-1.9.7 (16 Oct 2010)
+
+ 16 Oct 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -bcwipe-1.9.1.ebuild, +bcwipe-1.9.7.ebuild,
+ +files/bcwipe-1.9.7-fix_warnings.patch:
+ Version bump.
*bcwipe-1.9.6 (15 Oct 2010)
diff --git a/app-crypt/bcwipe/bcwipe-1.9.7.ebuild b/app-crypt/bcwipe/bcwipe-1.9.7.ebuild
new file mode 100644
index 000000000000..feedb787686c
--- /dev/null
+++ b/app-crypt/bcwipe/bcwipe-1.9.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/bcwipe/bcwipe-1.9.7.ebuild,v 1.1 2010/10/16 16:24:27 arfrever Exp $
+
+EAPI="3"
+
+inherit eutils versionator
+
+MY_PV="$(replace_version_separator 2 -)"
+
+DESCRIPTION="Secure file removal utility"
+HOMEPAGE="http://www.jetico.com/"
+SRC_URI="http://www.jetico.com/linux/BCWipe-${MY_PV}.tar.gz
+ doc? ( http://www.jetico.com/linux/BCWipe.doc.tgz )"
+
+LICENSE="bestcrypt"
+SLOT="0"
+IUSE="doc"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_warnings.patch"
+}
+
+src_test() {
+ echo "abc123" >> testfile
+ ./bcwipe -f testfile || die "bcwipe test failed"
+ [[ -f testfile ]] && die "test file still exists. bcwipe should have deleted it"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use doc ; then
+ dohtml -r ../bcwipe-help || die "dohtml failed"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "The BestCrypt drivers are not free - Please purchace a license from "
+ ewarn "http://www.jetico.com/"
+ ewarn "full details /usr/share/doc/${PF}/html/bcwipe-help/wu_licen.htm"
+}
diff --git a/app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch b/app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch
new file mode 100644
index 000000000000..f24a6acdb600
--- /dev/null
+++ b/app-crypt/bcwipe/files/bcwipe-1.9.7-fix_warnings.patch
@@ -0,0 +1,20 @@
+--- schemes.c
++++ schemes.c
+@@ -15,6 +15,7 @@
+ *
+ *******************************************************************/
+ #include "config.h"
++#include <ctype.h>
+ #include <stdlib.h>
+ #include <stdio.h>
+ #include <errno.h>
+--- wipe.c
++++ wipe.c
+@@ -42,6 +42,7 @@
+ #include <sys/ioctl.h>
+ #include <signal.h>
+ #include <time.h>
++#include <sys/time.h>
+ #include <ctype.h>
+
+ #if HAVE_SYS_DISKIO_H /* HP-UX */