summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2010-07-03 12:54:17 +0000
committerBenedikt Boehm <hollow@gentoo.org>2010-07-03 12:54:17 +0000
commitd1ee50913675fca98f30a3715a7837f564047147 (patch)
treea99c28d726a64f3e2640da4b752efa3c001c1537 /app-admin
parentVersion bump. (diff)
downloadgentoo-2-d1ee50913675fca98f30a3715a7837f564047147.tar.gz
gentoo-2-d1ee50913675fca98f30a3715a7837f564047147.tar.bz2
gentoo-2-d1ee50913675fca98f30a3715a7837f564047147.zip
initial ebuild, thanks to Gábor Vészi
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/chef-solr/ChangeLog12
-rw-r--r--app-admin/chef-solr/chef-solr-0.9.6.ebuild54
-rw-r--r--app-admin/chef-solr/files/confd/chef-solr20
-rw-r--r--app-admin/chef-solr/files/confd/chef-solr-indexer20
-rw-r--r--app-admin/chef-solr/files/initd/chef-solr39
-rw-r--r--app-admin/chef-solr/files/initd/chef-solr-indexer38
-rw-r--r--app-admin/chef-solr/files/solr.rb39
-rw-r--r--app-admin/chef-solr/metadata.xml10
8 files changed, 232 insertions, 0 deletions
diff --git a/app-admin/chef-solr/ChangeLog b/app-admin/chef-solr/ChangeLog
new file mode 100644
index 000000000000..249ff4425373
--- /dev/null
+++ b/app-admin/chef-solr/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-admin/chef-solr
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-solr/ChangeLog,v 1.1 2010/07/03 12:54:17 hollow Exp $
+
+*chef-solr-0.9.6 (03 Jul 2010)
+
+ 03 Jul 2010; Benedikt Böhm <hollow@gentoo.org> +chef-solr-0.9.6.ebuild,
+ +files/confd/chef-solr, +files/confd/chef-solr-indexer,
+ +files/initd/chef-solr, +files/initd/chef-solr-indexer, +files/solr.rb,
+ +metadata.xml:
+ initial ebuild, thanks to Gábor Vészi
+
diff --git a/app-admin/chef-solr/chef-solr-0.9.6.ebuild b/app-admin/chef-solr/chef-solr-0.9.6.ebuild
new file mode 100644
index 000000000000..06973fbfcae9
--- /dev/null
+++ b/app-admin/chef-solr/chef-solr-0.9.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-solr/chef-solr-0.9.6.ebuild,v 1.1 2010/07/03 12:54:17 hollow Exp $
+
+EAPI="2"
+USE_RUBY="ruby18"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Configuration management tool"
+HOMEPAGE="http://wiki.opscode.com/display/chef"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=net-misc/rabbitmq-server-1.7.0
+ =virtual/jre-1.6.0"
+
+ruby_add_rdepend "=app-admin/chef-${PV}
+ >=dev-ruby/libxml-1.1.3
+ >=dev-ruby/uuidtools-2.0.0"
+
+pkg_setup() {
+ enewgroup chef
+ enewuser chef -1 -1 /var/lib/chef chef
+}
+
+each_ruby_install() {
+ each_fakegem_install
+ ruby_fakegem_doins -r solr
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doinitd "${FILESDIR}/initd/chef-solr"
+ doconfd "${FILESDIR}/confd/chef-solr"
+
+ doinitd "${FILESDIR}/initd/chef-solr-indexer"
+ doconfd "${FILESDIR}/confd/chef-solr-indexer"
+
+ keepdir /etc/chef /var/lib/chef /var/log/chef /var/run/chef
+
+ insinto /etc/chef
+ doins "${FILESDIR}/solr.rb"
+
+ fowners chef:chef /etc/chef/{,solr.rb}
+ fowners chef:chef /var/{lib,log,run}/chef
+}
diff --git a/app-admin/chef-solr/files/confd/chef-solr b/app-admin/chef-solr/files/confd/chef-solr
new file mode 100644
index 000000000000..16e31986e905
--- /dev/null
+++ b/app-admin/chef-solr/files/confd/chef-solr
@@ -0,0 +1,20 @@
+# /etc/conf.d/chef-solr: config file for /etc/init.d/chef-solr
+
+# The configuration file to use.
+#CONFIGFILE="/etc/chef/solr.rb"
+
+# The user and group to set privilege to.
+#CHEF_USER="chef"
+#CHEF_GROUP="chef"
+
+# Log file location.
+#CHEF_SOLR_LOGFILE="/var/log/chef/solr.log"
+
+# Any radom options you want to pass to chef-solr.
+#CHEF_SOLR_OPTS=""
+
+# Path to the chef solr binary.
+#CHEF_SOLR_BINARY="/usr/bin/chef-solr"
+
+# PID file location.
+#CHEF_SOLR_PIDFILE="/var/run/chef/solr.pid"
diff --git a/app-admin/chef-solr/files/confd/chef-solr-indexer b/app-admin/chef-solr/files/confd/chef-solr-indexer
new file mode 100644
index 000000000000..32ce4a627386
--- /dev/null
+++ b/app-admin/chef-solr/files/confd/chef-solr-indexer
@@ -0,0 +1,20 @@
+# /etc/conf.d/chef-solr-indexer: config file for /etc/init.d/chef-solr-indexer
+
+# The configuration file to use.
+#CONFIGFILE="/etc/chef/solr.rb"
+
+# The user and group to set privilege to.
+#CHEF_USER="chef"
+#CHEF_GROUP="chef"
+
+# Log file location.
+#CHEF_SOLR_INDEXER_LOGFILE="/var/log/chef/solr-indexer.log"
+
+# Any radom options you want to pass to chef-solr-indexer.
+#CHEF_SOLR_INDEXER_OPTS=""
+
+# Path to the chef solr indexer binary.
+#CHEF_SOLR_INDEXER_BINARY="/usr/bin/chef-solr-indexer"
+
+# PID file location.
+#CHEF_SOLR_INDEXER_PIDFILE="/var/run/chef/solr-indexer.pid"
diff --git a/app-admin/chef-solr/files/initd/chef-solr b/app-admin/chef-solr/files/initd/chef-solr
new file mode 100644
index 000000000000..941736c1288f
--- /dev/null
+++ b/app-admin/chef-solr/files/initd/chef-solr
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net rabbitmq
+ after couchdb
+}
+
+CHEF_SOLR_BINARY=${CHEF_SOLR_BINARY:-/usr/bin/chef-solr}
+CHEF_SOLR_PIDFILE=${CHEF_SOLR_PIDFILE:-/var/run/chef/solr.pid}
+CHEF_SOLR_LOGFILE=${CHEF_SOLR_LOGFILE:-/var/log/chef/solr.log}
+CONFIGFILE=${CONFIGFILE:-/etc/chef/solr.rb}
+CHEF_USER=${CHEF_USER:-chef}
+CHEF_GROUP=${CHEF_GROUP:-chef}
+
+# TODO: this could be nicer
+DEFAULT_CHEF_DIRS=( /etc/chef /var/lib/chef /var/log/chef /var/run/chef )
+CHEF_DIRS=( ${CHEF_DIRS[@]:-${DEFAULT_CHEF_DIRS[@]}} )
+
+fix_dir_owners() {
+ for DIR in ${CHEF_DIRS[@]} ; do chown ${CHEF_USER}:${CHEF_GROUP} ${DIR} ; done
+}
+
+start() {
+ ebegin "Starting Chef SOLR"
+ fix_dir_owners
+ start-stop-daemon --start --quiet --chuid ${CHEF_USER}:${CHEF_GROUP} \
+ --pidfile ${CHEF_SOLR_PIDFILE} --name java --exec \
+ ${CHEF_SOLR_BINARY} -- -d -P ${CHEF_SOLR_PIDFILE} -c ${CONFIGFILE} \
+ -L ${CHEF_SOLR_LOGFILE} ${CHEF_SOLR_OPTS} > /dev/null
+ eend $?
+}
+
+stop() {
+ ebegin "Shutting down Chef SOLR"
+ start-stop-daemon --stop --quiet --pidfile ${CHEF_SOLR_PIDFILE}
+ eend $?
+}
diff --git a/app-admin/chef-solr/files/initd/chef-solr-indexer b/app-admin/chef-solr/files/initd/chef-solr-indexer
new file mode 100644
index 000000000000..b32261cf8556
--- /dev/null
+++ b/app-admin/chef-solr/files/initd/chef-solr-indexer
@@ -0,0 +1,38 @@
+#!/sbin/runscript
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need net chef-solr
+}
+
+CHEF_SOLR_INDEXER_BINARY=${CHEF_SOLR_INDEXER_BINARY:-/usr/bin/chef-solr-indexer}
+CHEF_SOLR_INDEXER_PIDFILE=${CHEF_SOLR_INDEXER_PIDFILE:-/var/run/chef/solr-indexer.pid}
+CHEF_SOLR_INDEXER_LOGFILE=${CHEF_SOLR_INDEXER_LOGFILE:-/var/log/chef/solr-indexer.log}
+CONFIGFILE=${CONFIGFILE:-/etc/chef/solr.rb}
+CHEF_USER=${CHEF_USER:-chef}
+CHEF_GROUP=${CHEF_GROUP:-chef}
+
+# TODO: this could be nicer
+DEFAULT_CHEF_DIRS=( /etc/chef /var/lib/chef /var/log/chef /var/run/chef )
+CHEF_DIRS=( ${CHEF_DIRS[@]:-${DEFAULT_CHEF_DIRS[@]}} )
+
+fix_dir_owners() {
+ for DIR in ${CHEF_DIRS[@]} ; do chown ${CHEF_USER}:${CHEF_GROUP} ${DIR} ; done
+}
+
+start() {
+ ebegin "Starting Chef SOLR indexer"
+ fix_dir_owners
+ start-stop-daemon --start --quiet --chuid ${CHEF_USER}:${CHEF_GROUP} \
+ --pidfile ${CHEF_SOLR_INDEXER_PIDFILE} --exec ${CHEF_SOLR_INDEXER_BINARY} \
+ -- -d -P ${CHEF_SOLR_INDEXER_PIDFILE} -L ${CHEF_SOLR_INDEXER_LOGFILE} \
+ -c ${CONFIGFILE} ${CHEF_SOLR_INDEXER_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Shutting down Chef SOLR indexer"
+ start-stop-daemon --stop --quiet --pidfile ${CHEF_SOLR_INDEXER_PIDFILE}
+ eend $?
+}
diff --git a/app-admin/chef-solr/files/solr.rb b/app-admin/chef-solr/files/solr.rb
new file mode 100644
index 000000000000..4d69373d30d8
--- /dev/null
+++ b/app-admin/chef-solr/files/solr.rb
@@ -0,0 +1,39 @@
+# Configuration File For Chef SOLR Indexer (chef-solr-indexer)
+#
+# The chef-indexer program runs on the Chef Server to generate search indexes
+# of node data stored in the Server's CouchDB store.
+#
+# Chef uses a Ruby DSL for configuration, and this file may contain some
+# Ruby idioms. First, symbols. These are designated by a colon sigil, ie,
+# :value. Second, in Ruby, everything but false and nil (no quotes or other
+# designations) is true, including true, the integer 0 and the string "false".
+# So to set the value of a setting to false, write:
+#
+# some_setting false
+#
+# Third, Ruby class methods can be used, for example we tell the log to show
+# the current time stamp with Chef::Log::Formatter.show_time, below.
+#
+# log_location specifies where the indexer should log to.
+# valid values are: a quoted string specifying a file, or STDOUT with
+# no quotes. When run as a daemon (default), STDOUT will produce no output.
+
+log_location "/var/log/chef/solr.log"
+
+# search_index_path specifies where the indexer should store the indexes.
+# valid value is any filesystem directory location.
+
+search_index_path "/var/lib/chef/search_index"
+
+solr_jetty_path "/var/lib/chef/solr/jetty"
+solr_home_path "/var/lib/chef/solr/home"
+solr_data_path "/var/lib/chef/solr/data"
+solr_heap_size "256M"
+
+# Mixlib::Log::Formatter.show_time specifies whether the chef-client log should
+# contain timestamps.
+# valid values are true or false (no quotes, see above about Ruby idioms). The
+# printed timestamp is rfc2822, for example:
+# Fri, 31 Jul 2009 19:19:46 -0600
+
+Mixlib::Log::Formatter.show_time = true
diff --git a/app-admin/chef-solr/metadata.xml b/app-admin/chef-solr/metadata.xml
new file mode 100644
index 000000000000..b263a5bc4f28
--- /dev/null
+++ b/app-admin/chef-solr/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>hollow@gentoo.org</email>
+ <name>Benedikt Böhm</name>
+ </maintainer>
+</pkgmetadata>
+