summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-06-07 21:12:28 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-06-07 21:12:28 +0000
commit5a26ca575106015a40d4aa48af7737ea16343266 (patch)
tree3dbe93bbdb050627f00ec9066977f40097f80d87
parentsys-boot/plymouth-0.8.3-r3: Fixed libdir in plugin install. (diff)
downloadgentoo-2-5a26ca575106015a40d4aa48af7737ea16343266.tar.gz
gentoo-2-5a26ca575106015a40d4aa48af7737ea16343266.tar.bz2
gentoo-2-5a26ca575106015a40d4aa48af7737ea16343266.zip
Use rc_ulimit to set file limit, see bug #268396, comment #19
(Portage version: 2.1.9.42/cvs/Linux x86_64)
-rw-r--r--net-misc/tor/ChangeLog8
-rw-r--r--net-misc/tor/files/tor.confd3
-rw-r--r--net-misc/tor/tor-0.2.1.30-r2.ebuild94
3 files changed, 104 insertions, 1 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 5e88cb4edaa3..e642b9f77245 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.255 2011/05/30 23:25:44 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.256 2011/06/07 21:12:28 blueness Exp $
+
+*tor-0.2.1.30-r2 (07 Jun 2011)
+
+ 07 Jun 2011; Anthony G. Basile <blueness@gentoo.org> +tor-0.2.1.30-r2.ebuild,
+ +files/tor.confd:
+ Use rc_ulimit to set file limit, see bug #268396, comment #19
*tor-0.2.2.27_beta (30 May 2011)
diff --git a/net-misc/tor/files/tor.confd b/net-misc/tor/files/tor.confd
new file mode 100644
index 000000000000..4195bf3237b2
--- /dev/null
+++ b/net-misc/tor/files/tor.confd
@@ -0,0 +1,3 @@
+#
+# Set the file limit
+rc_ulimit="-n 30000"
diff --git a/net-misc/tor/tor-0.2.1.30-r2.ebuild b/net-misc/tor/tor-0.2.1.30-r2.ebuild
new file mode 100644
index 000000000000..d4df00eb4d75
--- /dev/null
+++ b/net-misc/tor/tor-0.2.1.30-r2.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.1.30-r2.ebuild,v 1.1 2011/06/07 21:12:28 blueness Exp $
+
+EAPI=2
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+MY_PV=${PV/_/-}
+SRC_URI="http://www.torproject.org/dist/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-1.2"
+# The tordns patch for tsocks avoids some leakage of information thus raising anonymity
+RDEPEND="${DEPEND}
+ net-proxy/tsocks[tordns]"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
+ epatch "${FILESDIR}"/${PN}-0.2.1.19-logrotate.patch
+
+ einfo "Regenerating autotools files ..."
+ epatch "${FILESDIR}"/${PN}-0.2.1.30-respect-CFLAGS.patch
+ eautoreconf || die "eautoreconf failed"
+
+ # Normally tor uses a bundled libevent fragment to provide
+ # asynchronous DNS requests. This is generally a bad idea, but at
+ # the moment the official libevent does not have the 0x20 hack, so
+ # anonymity is higher with the bundled variant. Remove patch as
+ # soon as upstream has installed the autoconf option to use
+ # system's libevent. This hasn't happened, so we
+ # have to live with the bundled libevent for this release, as the
+ # current version in tree won't suffice for tor to build
+ # See http://bugs.noreply.org/flyspray/index.php?do=details&id=920
+ # for upstream's report
+ # Let's revisit this when libevent-2* is unmasked
+ # use bundledlibevent || epatch "${FILESDIR}"/${PN}-0.2.1.5-no-internal-libevent.patch
+}
+
+src_configure() {
+ # Upstream isn't sure of all the user provided CFLAGS that
+ # will break tor, but does recommend against -fstrict-aliasing.
+ # We'll filter-flags them here as we encounter them.
+ filter-flags -fstrict-aliasing
+ econf $(use_enable debug)
+}
+
+src_install() {
+ # allow the tor user more open files to avoid errors, see bug 251171
+ newconfd "${FILESDIR}"/tor.confd tor
+
+ newinitd "${FILESDIR}"/tor.initd-r4 tor
+ emake DESTDIR="${D}" install || die
+ keepdir /var/{lib,log,run}/tor
+
+ dodoc README ChangeLog AUTHORS ReleaseNotes \
+ doc/{HACKING,TODO}
+
+ fperms 750 /var/lib/tor /var/log/tor
+ fperms 755 /var/run/tor
+ fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
+
+ insinto /etc/tor/
+ doins "${FILESDIR}"/torrc
+
+ insinto /etc/logrotate.d
+ newins contrib/tor.logrotate tor
+}
+
+pkg_postinst() {
+ elog
+ elog "We created a configuration file for tor, /etc/tor/torrc, but you can"
+ elog "change it according to your needs. Use the torrc.sample that is in"
+ elog "that directory as a guide. Also, to have privoxy work with tor"
+ elog "just add the following line"
+ elog
+ elog "forward-socks4a / localhost:9050 ."
+ elog
+ elog "to /etc/privoxy/config. Notice the . at the end!"
+ elog
+}